Opened 4 years ago

Closed 4 years ago

Last modified 28 minutes ago

#1068 closed bug (Fixed)

"Error getting torrent info" on deluge-console info command

Reported by: Murz Owned by: andar
Priority: major Milestone: 1.2.0
Component: other/unknown Version: 1.2.0_rc3
Keywords: Cc:

Description

I have an Kubuntu Karmic AMD64 & Deluge-torrent 1.2.0~rc3-2~karmic~ppa1
Deluge started as daemon from user murz:

/usr/bin/python /usr/bin/deluged -d

And the command

deluge-console info

from user murz shows the error:

murz@kit:~$ deluge-console info
                               
Name: S21                      
ID: 0e9e540747ebe25a613a93a181b31de9c8f934bd
State: Paused                               
Size: 587.5 MiB/587.5 MiB Ratio: 1.041
Error getting torrent info: [Failure instance: Traceback: <type 'exceptions.AttributeError'>: 'ConsoleUI' object has no attribute 'screen'
/usr/lib/python2.6/dist-packages/twisted/internet/tcp.py:463:doRead
/usr/lib/pymodules/python2.6/deluge/ui/client.py:176:dataReceived
/usr/lib/python2.6/dist-packages/twisted/internet/defer.py:243:callback
/usr/lib/python2.6/dist-packages/twisted/internet/defer.py:312:_startRunCallbacks
--- <exception caught here> ---
/usr/lib/python2.6/dist-packages/twisted/internet/defer.py:328:_runCallbacks
/usr/lib/pymodules/python2.6/deluge/ui/console/commands/info.py:119:on_torrents_status
/usr/lib/pymodules/python2.6/deluge/ui/console/commands/info.py:228:show_info
/usr/lib/pymodules/python2.6/deluge/ui/console/main.py:251:set_batch_write
]

deluge-gtk connects and works normally and shows all my torrents without any errors.

Change History (3)

comment:1 Changed 4 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in rc4

comment:2 Changed 4 years ago by Murz

Thank's! Confirm working on kubuntu karmic & deluge 1.2.0_rc4!
But found another bug in console, described here: http://dev.deluge-torrent.org/ticket/1088

comment:3 Changed 28 minutes ago by keretamalam

I am about to leave and cannot look into this further right now, but I do want to mention that relying on pkg-config itself is not a problem (as you said, we also use it later), the problem is that on some systems, the .pc file for pkg-config is supplying wrong information (whereas on yours, it's botan-config that is wrong), so that's why I'm trying to make it work with both (while one of them is bad).

Unit Link Terbaik di Indonesia Commonwealth Life Investra Link
Cipto Junaedy
Cipto Junaedy

Note: See TracTickets for help on using tickets.