Opened 4 years ago

Closed 4 years ago

#1128 closed bug (Fixed)

Package 'deluge' in the PPA doesn't depend on deluged, but fails silently on "Run Daemon"

Reported by: lfaraone Owned by:
Priority: minor Milestone: 1.2.0
Component: Packaging Version: 1.2.0
Keywords: Cc:

Description

Steps to reproduce:

  • Install Deluge from the Karmic repositories
  • Disable classic mode and set up the daemon
  • Enable the PPA and upgrade 'deluge'. This will conflict with deluge-core, so it'll be removed.
  • Click on "Run Daemon" in the dialog.

The window freezes for a moment, then disappears. The daemon is not started, and it initially appeared to me that the window had just closed on its own.

'deluge' does not depend on 'deluged', so when you try to start the Daemon from /usr/bindeluge-gtk you get the following in the console:

[ERROR   ] 22:01:32 client:558 Unable to start daemon!
[ERROR   ] 22:01:32 client:559 [Errno 2] No such file or directory
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/deluge/ui/client.py", line 556, in start_daemon
    subprocess.call(["deluged", "--port=%s" % port, "--config=%s" % config])
  File "/usr/lib/python2.6/subprocess.py", line 470, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
[ERROR   ] 22:01:32 connectionmanager:429 Connection to host 
[...abbreviated...]
[ERROR   ] 22:01:35 connectionmanager:429 Connection to host failed..
Unhandled error in Deferred:
Traceback (most recent call last):
Failure: twisted.internet.error.ConnectionRefusedError: Connection was refused by other side: 111: Connection refused.

This is a potential upgrade issue.

There are two things we can do:

  • Pull in deluged as a dep of deluge
  • Notify the user with an error that the deluge daemon isn't present, and optionally give the user an apt: URL which installs it for them automagically

Change History (2)

comment:1 Changed 4 years ago by andar

We can add an error dialog stating that there is no 'deluged' executable available, but having an APT url would be wrong since not everyone uses apt.

comment:2 Changed 4 years ago by andar

  • Milestone set to 1.2.0
  • Resolution set to fixed
  • Status changed from new to closed

I've added the error dialog in [6098]. The dependency issue will need to be taken up with the Debian maintainer cgreco.

Note: See TracTickets for help on using tickets.