Opened 7 years ago

Closed 2 years ago

#1330 closed bug (Fixed)

[Scheduler] Torrents in paused mode after restarting deluge while in red zone

Reported by: tim-m89 Owned by: Cas
Priority: trivial Milestone: 1.3.13
Component: Plugin Version: 1.3.0_dev
Keywords: Cc:

Description

deluge:1.3.0-rc1 libtorrent: 0.14.10.0

Upon transitioning from the scheduler red zone to green, torrents start up again but except for a few which are now in paused mode. How did they get in paused mode?

To be a little more detailed, I think it happens a little like this:

I have 4 torrents, none of which are in paused mode and I am currently in the scheduler's active green zone but I have the queue set to only 2 active like so:

#1 A #2 A #3 Q #4 Q

Upon reaching the red zone the torrents stop but the active ones get assigned a mode of paused so that when the next green zone arrives the lower priority torrents are going instead like so:

#1 P #2 P #3 A #4 A

If it helps to reproduce the bug I am currently starting and stopping deluge client & daemon during each red zone.

Change History (9)

comment:1 Changed 7 years ago by tim-m89

Those above were not supposed to be track links but the numbers of of each torrent's priority like so:

#1 A
#2 A
#3 Q
#4 Q

#1 P
#2 P
#3 A
#4 A

comment:2 Changed 7 years ago by johnnyg

When the scheduler is in the red zone it pauses the libtorrent session.

The problem is that if you shutdown deluged while the session is paused, it will pause all torrents.

Not really sure how to avoid that...

comment:3 Changed 7 years ago by damoxc

Could use a state file to keep track of it...

comment:4 Changed 7 years ago by andar

It might just be easier to set the active torrent limit to 0 in the red state instead of pausing the session.

comment:5 Changed 7 years ago by damoxc

  • Milestone changed from 1.3.0 to 1.4.0

comment:6 Changed 7 years ago by Cas

  • Priority changed from major to trivial

comment:7 Changed 5 years ago by Cas

  • Milestone changed from 1.4.0 to 1.3.x
  • Summary changed from scheduler plugin causing torrents to be in paused mode to [Scheduler] Torrents in paused mode after restarting deluge while in red zone

comment:8 Changed 2 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.13
  • Owner set to Cas
  • Status changed from new to assigned

comment:9 Changed 2 years ago by Cas

  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed 1.3-stabe: [73152558317d47d]

Note: See TracTickets for help on using tickets.