Opened 7 years ago

Closed 7 years ago

#1364 closed bug (Fixed)

Error when saving preferences

Reported by: iDope Owned by: andar
Priority: major Milestone: 1.3.1
Component: Unknown Version: 1.3.0
Keywords: Cc:

Description

I have been able to produce this error on version 1.3.0 and also on the current git snapshot as of the reporting of this ticket. It is not present in version 1.2.3

When the preferences are closed using the OK button in the GTK ui the following error pops up multiple times:

ERROR   ] 14:48:42 client:454 'NoneType' object has no attribute 'rpcserver'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/deluge/ui/client.py", line 452, in call
    m = self.__daemon.rpcserver.get_object_method(method)
AttributeError: 'NoneType' object has no attribute 'rpcserver'
Unhandled error in Deferred:
Traceback (most recent call last):
Failure: exceptions.AttributeError: 'NoneType' object has no attribute 'rpcserver'

The behavior after this is either the preferences window does not close at all or if it does close, it can not be opened again without restarting deluge.

This was tested on Arch Linux.

Attachments (2)

deluge-linux.log (61.2 KB) - added by iDope 7 years ago.
Deluge debug log on linux
deluge-windows.log (73.6 KB) - added by iDope 7 years ago.
Deluge debug log on windows

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by iDope

  • Type changed from defect to bug

The same problem was also reproduces on Windows, here is the output from deluge-debug.exe:

[ERROR   ] 21:32:13 __init__:1080 'NoneType' object has no attribute 'rpcserver'

Traceback (most recent call last):
  File "deluge\ui\client.py", line 452, in call
AttributeError: 'NoneType' object has no attribute 'rpcserver'
Unhandled error in Deferred:
Traceback (most recent call last):
Failure: exceptions.AttributeError: 'NoneType' object has no attribute 'rpcserve
r'

On linux the problem can be avoided if classic mode is not used and the daemon is started manually and connected to using the interface.

comment:2 Changed 7 years ago by johnnyg

  • Milestone changed from 1.3.0 to 1.3

comment:3 Changed 7 years ago by johnnyg

  • Milestone changed from 1.3.x to 1.3.1

comment:4 Changed 7 years ago by johnnyg

I have not been able to reproduce this. Have you tried (backing up and) deleting your config folder?

comment:5 Changed 7 years ago by johnnyg

  • Status changed from new to pending

comment:6 Changed 7 years ago by iDope

  • Status changed from pending to new

Yes. I have tried to launch it with a non-existant .config in linux and it still produces the above result with the default generated config. Obviously it has trouble finding the daemon in classic mode.

comment:7 Changed 7 years ago by iDope

Also confirmed this on windows. I have installed it using "deluge-1.3.0-win32-setup.exe".

The problem appears after a fresh install on both linux and windows. And does not get resolved even if the initial configuration folders /home/user/.config/deluge (in linux) or C:\Users\AppData?\roaming\deluge\* (in Windows 7) are deleted. After running deluge the basic config is regenerated and the problem appears again when the program is restarted.

comment:8 Changed 7 years ago by johnnyg

I still cannot reproduce this on windows or linux. Could you provide a full debug log? (deluge -L debug -l deluge.log)

Changed 7 years ago by iDope

Deluge debug log on linux

Changed 7 years ago by iDope

Deluge debug log on windows

comment:9 Changed 7 years ago by johnnyg

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the logs. This has been fixed in git and will be in the next release.

Note: See TracTickets for help on using tickets.