Opened 7 years ago

Closed 6 years ago

#1373 closed bug (Fixed)

[win32] Move storage problem with non-ascii paths

Reported by: Oleg Owned by: Cas
Priority: minor Milestone: 1.3.2
Component: Core Version: master (git)
Keywords: utf8 Cc: o.shirochenkov@…

Description

Problem:

Upgraded Deluge from 1.2.3 to 1.3.0 on Ubuntu Server 10.04. And I found the BUG, when I save torrent into directory with cyrillic chars.

Example:

I have a dir for my video files /media/STORAGE01/ВИДЕО/ФИЛЬМЫ but Deluge ignores "/ВИДЕО/ФИЛЬМЫ" and saves files to "/media/STORAGE01", and after dounload complete I can't move files to my ../ВИДЕО directory.

Information:

Daemon: 1.3.0 on Ubuntu Server 10.04 Client: 1.3.0 on Windows 7 Home Premium

Attachments (2)

deluge_debug_log.gif (18.6 KB) - added by Oleg 7 years ago.
deluged.log (958 bytes) - added by sellsky 6 years ago.
move storage to /tmp/teståäö failure

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 years ago by Oleg

  • Milestone changed from Future to 1.3.1

comment:2 Changed 7 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 1.3-stable.

comment:3 Changed 7 years ago by Oleg

  • Milestone changed from 1.3.1 to 1.3.x
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 7 years ago by Thump

  • Cc o.shirochenkov@… added
  • Keywords utf8 added; ascii cyrillic folders removed
  • Milestone changed from 1.3.x to 1.3.2
  • Priority changed from major to minor
  • Summary changed from Cyrillic directories fail to deluged: cyrillic path to downloaded torrents
  • Version changed from 1.3.0 to 1.3.1

Oleg, could we see debug-level log?

Faq

Changed 7 years ago by Oleg

comment:5 Changed 7 years ago by Cas

  • Summary changed from deluged: cyrillic path to downloaded torrents to Move storage problem with cyrillic paths

comment:6 Changed 7 years ago by negge

The same bug appears when the destination directory contains Swedish characters (åäö)

comment:7 Changed 7 years ago by Thump

  • Summary changed from Move storage problem with cyrillic paths to Move storage problem with non-ascii paths

This is a problem with encodings and utf8. There are a lot of such problems for the whole Deluge project.

comment:8 Changed 7 years ago by Cas

  • Resolution set to worksforme
  • Status changed from reopened to closed

I cannot replicate this on Ubuntu or Windows XP, using the suggested characters.

Please reopen this ticket if you have debug logs or more detailed information (Deluge >= 1.3.1)

Replying to Thump:

This is a problem with encodings and utf8. There are a lot of such problems for the whole Deluge project.

If you could start a topic in the forum about the issues that would help.

comment:9 Changed 7 years ago by Cas

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have actually spotted the problem on windows xp.

Steps to reproduce:

From within Deluge, using Move Storage, create a folder using the name: åäö A second folder named åäö will be created which seems to be the core of the issue as Deluge is internally converting åäö to åäö but still showing åäö to the user.

This seems to be isolated to windows versions of Deluge as I cannot replicate on Ubuntu.

comment:10 Changed 7 years ago by Cas

  • Summary changed from Move storage problem with non-ascii paths to [win32] Move storage problem with non-ascii paths

comment:11 Changed 7 years ago by Cas

  • Owner set to Cas
  • Status changed from reopened to accepted

comment:12 Changed 7 years ago by Cas

  • Resolution set to fixed
  • Status changed from accepted to closed

1.3-stable: 93091fbe23

Changed 6 years ago by sellsky

move storage to /tmp/teståäö failure

comment:13 follow-up: Changed 6 years ago by sellsky

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.3.1 to git master

I get Deluge from current git master branch, start deluged in ArchLinux?, and then move torrent to /tmp/teståäö, with no success (see deluged.log I attached).

Maybe by any chance the problem is still here?

comment:14 Changed 6 years ago by Cas

Can you please test against the git 1.3-stable branch.

comment:15 in reply to: ↑ 13 Changed 6 years ago by Cas

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to sellsky:

I get Deluge from current git master branch, start deluged in ArchLinux?, and then move torrent to /tmp/teståäö, with no success (see deluged.log I attached).

Maybe by any chance the problem is still here?

On reviewing your log this is not the same. When checking the path your operating system is trying to convert to ASCII instead of UTF8 or Unicode. See this helpful Django FAQ

Note: See TracTickets for help on using tickets.