Opened 7 years ago

Closed 7 years ago

#1484 closed defect (Fixed)

deluge-console "info -v" gives 'ConsoleUI' object has no attribute 'screen'

Reported by: non7top Owned by:
Priority: major Milestone: Future
Component: Unknown Version: 1.3.1
Keywords: Cc:

Description (last modified by damoxc)

$ deluge-console "info -v"

Name: The.Brothers.Bloom.2008.BDRip.by.gjiAm.tRuAVC.mkv
ID: 67e694caf5eabb9c4ab3a5ca47d3906f7a15de5f
State: Seeding Up Speed: 19.5 KiB/s ETA: 3d 2h
Seeds: 0 (1) Peers: 1 (0) Availibility: 0.00
Size: 2.9 GiB/2.9 GiB Ratio: 0.279
  ::Files
Error getting torrent info: [Failure instance: Traceback: <type 'exceptions.AttributeError'>: 'ConsoleUI' object has no attribute 'screen'
/usr/lib/python2.6/site-packages/twisted/internet/tcp.py:460:doRead
/usr/lib/python2.6/site-packages/deluge/ui/client.py:183:dataReceived
/usr/lib/python2.6/site-packages/twisted/internet/defer.py:318:callback
/usr/lib/python2.6/site-packages/twisted/internet/defer.py:424:_startRunCallbacks
--- <exception caught here> ---
/usr/lib/python2.6/site-packages/twisted/internet/defer.py:441:_runCallbacks
/usr/lib/python2.6/site-packages/deluge/ui/console/commands/info.py:119:on_torrents_status
/usr/lib/python2.6/site-packages/deluge/ui/console/commands/info.py:192:show_info
]


 $ deluge --version
1.3.1

Change History (3)

comment:1 Changed 7 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed.

comment:2 Changed 7 years ago by non7top

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from other (please specify) to 1.3.1

Any comment, please? I'm using latest release (1.3.1) and the issue is present.

comment:3 Changed 7 years ago by damoxc

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from reopened to closed

...in git. It will be in the next release.

Note: See TracTickets for help on using tickets.