Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1510 closed bug (Fixed)

Can't create a torrent

Reported by: shnurapet Owned by: Cas
Priority: major Milestone: 1.3.2
Component: GTK UI Version: 1.3.0_dev
Keywords: Cc:

Description

architecture: x86_64 cmdline: /usr/bin/python /usr/bin/deluge-gtk component: deluge executable: /usr/bin/deluge-gtk kernel: 2.6.35.10-74.fc14.x86_64 reason: createtorrentdialog.py:294:_on_button_save_clicked:IndexError: list index out of range release: Fedora release 14 (Laughlin) time: 1296760033 uid: 500

backtrace


createtorrentdialog.py:294:_on_button_save_clicked:IndexError: list index out of range

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/deluge-1.3.900_dev-py2.7.egg/deluge/ui/gtkui/createtorrentdialog.py", line 294, in _on_button_save_clicked

trackers[tier].append(tracker)

IndexError?: list index out of range

Local variables in innermost frame: widget: <gtk.Button object at 0x34de9b0 (GtkButton? at 0x3668550)> trackers: [[]] file_filter: <gtk.FileFilter? object at 0x34de230 (GtkFileFilter? at 0x3676380)> self: <deluge.ui.gtkui.createtorrentdialog.CreateTorrentDialog? instance at 0x34e0950> chooser: <gtk.FileChooserDialog? object at 0x34defa0 (GtkFileChooserDialog? at 0x326d760)> is_remote: False tracker: 'http://tracker.openbittorrent.com/announce' result: '/home/shnurapet/gnome3_test_20110203.torrent' tier: 1 path: '/mnt/HD2/gnome3_test_20110203' response: -5

reproduce


  1. Create a torrent

2. 3.

Change History (10)

comment:1 Changed 7 years ago by shnurapet

Oops! Sorry...

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/deluge-gtk
component: deluge
executable: /usr/bin/deluge-gtk
kernel: 2.6.35.10-74.fc14.x86_64
package: deluge-1.3.0-1.fc14
reason: createtorrentdialog.py:294:_on_button_save_clicked:IndexError: list index out of range
release: Fedora release 14 (Laughlin)
time: 1296760033
uid: 500

backtrace
-----
createtorrentdialog.py:294:_on_button_save_clicked:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge-1.3.900_dev-py2.7.egg/deluge/ui/gtkui/createtorrentdialog.py", line 294, in _on_button_save_clicked
    trackers[tier].append(tracker)
IndexError: list index out of range

Local variables in innermost frame:
widget: <gtk.Button object at 0x34de9b0 (GtkButton at 0x3668550)>
trackers: [[]]
file_filter: <gtk.FileFilter object at 0x34de230 (GtkFileFilter at 0x3676380)>
self: <deluge.ui.gtkui.createtorrentdialog.CreateTorrentDialog instance at 0x34e0950>
chooser: <gtk.FileChooserDialog object at 0x34defa0 (GtkFileChooserDialog at 0x326d760)>
is_remote: False
tracker: 'http://tracker.openbittorrent.com/announce'
result: '/home/shnurapet/gnome3_test_20110203.torrent'
tier: 1
path: '/mnt/HD2/gnome3_test_20110203'
response: -5

reproduce
-----
1. Create a torrent
2.
3.



comment:2 Changed 7 years ago by Cas

  • Component changed from other to gtkui
  • Milestone changed from Future to 1.4.0
  • Type changed from defect to bug

What version of deluge is this?

comment:3 Changed 7 years ago by shnurapet

Hi. This is the version from git.

comment:4 Changed 7 years ago by Cas

I cannot reproduce on Ubuntu 10.10 64-bit.

comment:5 Changed 7 years ago by shnurapet

Updated from git, strongly reproducible here on Fedora 14.

It only works if no tracker specified.

$ rpm -qa |grep python
gnome-python2-gtkhtml2-2.25.3-26.fc14.1.x86_64
python-twisted-web-10.1.0-1.fc14.x86_64
python-BeautifulSoup-3.0.8.1-2.fc14.noarch
python-twisted-core-10.1.0-3.fc14.x86_64
python-pyblock-0.52-1.fc14.x86_64
boost-python-1.44.0-7.fc14.x86_64
python-telepathy-0.15.18-1.fc14.noarch
cracklib-python-2.8.16-4.fc14.x86_64
python-markupsafe-0.9.2-4.fc14.x86_64
python-simplejson-2.1.3-1.fc14.x86_64
python-beaker-1.5.3-5.fc14.noarch
gnome-python2-desktop-2.32.0-2.fc14.x86_64
python-2.7-8.fc14.1.x86_64
gnome-python2-libegg-2.25.3-26.fc14.1.x86_64
python-decorator-3.2.1-1.fc14.noarch
python-crypto-2.3-2.fc14.1.x86_64
python-xlib-0.15-0.3.rc1.fc14.noarch
gnome-python2-2.28.1-3.fc14.x86_64
gnome-python2-libwnck-2.32.0-2.fc14.x86_64
python-iniparse-0.4-2.fc14.noarch
gnome-python2-applet-2.32.0-2.fc14.x86_64
python-zope-interface-3.6.1-7.fc14.x86_64
python-urlgrabber-3.9.1-7.fc14.noarch
python-tempita-0.4-5.fc14.noarch
python-lxml-2.2.8-1.fc14.x86_64
gnome-python2-gnomevfs-2.28.1-3.fc14.x86_64
python-slip-dbus-0.2.13-1.fc14.noarch
python-cryptsetup-0.0.10-3.fc14.x86_64
python-iwlib-0.1-3.fc14.x86_64
notify-python-0.1.1-16.fc14.x86_64
gamin-python-0.1.10-8.fc14.x86_64
python-GnuPGInterface-0.3.2-7.fc14.noarch
python-httplib2-0.6.0-3.fc14.noarch
gnome-python2-canvas-2.28.1-3.fc14.x86_64
python-libs-2.7-8.fc14.1.x86_64
libxml2-python-2.7.7-2.fc14.x86_64
dbus-python-0.83.0-7.fc14.x86_64
rpm-python-4.8.1-5.fc14.x86_64
python-pycurl-7.19.0-7.fc14.x86_64
gstreamer-python-0.10.19-1.fc14.x86_64
python-fpconst-0.7.3-7.fc14.noarch
python-bugzilla-0.6.1-3.fc14.noarch
libproxy-python-0.4.4-7.fc14.noarch
gnome-python2-gconf-2.28.1-3.fc14.x86_64
python-feedparser-4.1-12.fc14.noarch
python-boto-1.9b-5.fc14.noarch
gnome-python2-gnomekeyring-2.32.0-2.fc14.x86_64
policycoreutils-python-2.0.83-33.10.fc14.x86_64
newt-python-0.52.12-1.fc14.x86_64
farsight2-python-0.0.21-2.fc14.x86_64
python-devel-2.7-8.fc14.1.x86_64
python-chardet-2.0.1-2.fc14.noarch
python-mako-0.3.4-2.fc14.noarch
rb_libtorrent-python-0.14.11-1.fc14.x86_64
gnome-python2-gnome-2.28.1-3.fc14.x86_64
abrt-addon-python-1.1.14-1.fc14.x86_64
python-setuptools-0.6.14-3.fc14.noarch
python-nose-0.11.3-5.fc14.noarch
python-deltarpm-3.6-0.2.20100708git.fc14.x86_64
python-nss-0.9-9.fc14.x86_64
at-spi-python-1.32.0-2.fc14.x86_64
python-slip-gtk-0.2.13-1.fc14.noarch
python-slip-0.2.13-1.fc14.noarch
setools-libs-python-3.3.7-11.fc14.x86_64
libsemanage-python-2.0.45-5.fc14.x86_64
python-paste-1.7.4-7.fc14.noarch
python-meh-0.10-2.fc14.noarch
gnome-python2-bonobo-2.28.1-3.fc14.x86_64
gnome-python2-extras-2.25.3-26.fc14.1.x86_64
audit-libs-python-2.0.4-4.fc14.x86_64
libuser-python-0.56.18-3.fc14.x86_64
libselinux-python-2.0.96-6.fc14.1.x86_64
python-virtkey-0.50-8.fc14.x86_64

comment:6 Changed 7 years ago by Cas

  • Milestone changed from 1.4.0 to 1.3.2
  • Owner set to Cas
  • Status changed from new to accepted

comment:7 Changed 7 years ago by Cas

It seems that you have put the tracker in tier 1 with no tier0?

This error can also occur in 1.3.1.

comment:8 Changed 7 years ago by shnurapet

I add 3 trackers and give them 1, 2, 3, like this:

  1. http://tracker.openbittorrent.com/announce
  1. udp://tracker.openbittorrent.com:80/announce
  1. http://retracker.local/announce

comment:9 Changed 7 years ago by Cas

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in 1.3-stable: 03689a805b

comment:10 Changed 7 years ago by shnurapet

Thanks!

Note: See TracTickets for help on using tickets.