Opened 7 years ago

Closed 6 years ago

#1554 closed bug (Fixed)

Stop Seeding on Share Ratio Fails for Partially Selected Torrents

Reported by: robg Owned by:
Priority: minor Milestone: 1.3.4
Component: Core Version: 1.3.1
Keywords: Cc:

Description

Bug Report

If you select only one file (or fewer than all the files) from a multiple file torrent to download, and have the "Stop seeding when share ratio reaches" option selected then the torrent will never automatically stop seeding.

Steps to Reproduce

  1. In Preferences under "Queue" check the option for "Stop Seeding when share ratio reaches" from the bottom third section labeled "Seeding". Click OK to save preferences
  2. Open a torrent file containing multiple files for downloading to Deluge using the GUI.
  3. From the Add Torrent panel, select the Files tab.
  4. Uncheck one of the files to be downloaded.
  5. Add the torrent to the active queue.

Expected result: torrent will stop seeding when ratio reaches the specified value.

Actual result: torrent continues seeding indefinitely

Additional Notes

Single file & multiple file torrents where all the files are downloaded do correctly stop seeding at the specified ratio. This only happens when the torrent has some file not selected for download.

Change History (5)

comment:1 Changed 7 years ago by Cas

  • Milestone changed from Future to 1.3.x
  • Type changed from defect to bug

comment:2 Changed 7 years ago by robg

#1264 is probably a duplicate of this ticket

comment:3 Changed 6 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.3

I managed to repeat this but am unsure if this is Deluge or libtorrent related as it needs more debugging.

comment:4 Changed 6 years ago by Cas

  • Milestone changed from 1.3.3 to 1.3.x

comment:5 Changed 6 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.4
  • Resolution set to fixed
  • Status changed from new to closed

Although not tested for specifically this issue should be fixed by these two commits:

1f5cfd16e

2ae936df4

Note: See TracTickets for help on using tickets.