Opened 7 years ago

Closed 6 years ago

#1562 closed patch (Fixed)

Javascript error in Web UI when re-opening preferences

Reported by: wump Owned by: damoxc
Priority: minor Milestone: 1.3.2
Component: Web UI Version: 1.3.0_dev
Keywords: Cc:

Description

Steps to reproduce:

  • In the Web UI, click "preferences"
  • Go to the plugins page
  • Select a plugin
  • Click OK
  • Click "preferences" again -- a Javascript error triggers, because of the clearSelection and onPluginSelect cannot handle empty selection

See attached patch (1 line) to fix.

Attachments (1)

plugins_selection_fix.patch (611 bytes) - added by wump 7 years ago.
Fix patch

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by wump

Fix patch

comment:1 Changed 7 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.2
  • Type changed from defect to patch

comment:2 Changed 6 years ago by damoxc

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.