Opened 7 years ago

Closed 5 years ago

Last modified 7 months ago

#1686 closed bug (Fixed)

Alltorrent.py sometimes loading over diffrent mode

Reported by: karaken12 Owned by: nick
Priority: major Milestone: 2.x
Component: Console UI Version: 1.3.0_dev
Keywords: Cc: mail.nogare@…

Description

When showing the detail view of a torrent 'Waiting for Torrent State' is displayed, then one of two things happens: sometimes the view switches back to the main view temporarily, until the state is loaded, and sometimes it switches back permanently (until you press right again).

Change History (11)

comment:1 Changed 7 years ago by Cas

  • Milestone changed from Future to 1.4.0
  • Type changed from defect to bug

Please can you specify if you are using git master and if this refers to the new console

comment:2 Changed 7 years ago by Cas

  • Owner set to nick
  • Status changed from new to assigned

comment:3 Changed 7 years ago by nick

  • Status changed from assigned to pending

I can't reproduce this. The only way things should go back to the torrent overview is if you hit 'q' or the right arrow. Otherwise the view just sits on "Waiting for torrent info..."

I've fixed a small bug where some keypresses that didn't make sense were being interpreted before the torrent state arrived, but I don't think that problem was related to what you're describing here.

Can you give me a more detailed rundown of the sequence of keypresses you did to make this happen and also let me know if by chance the other fix I put in fixes this for you?

comment:4 Changed 7 years ago by karaken12

  • Status changed from pending to new

The other fix has had an effect, but it hasn't fixed this problem. The behaviour is triggered simply by pressing right on any torrent. The machine I am running Deluge on has many torrents and not much RAM, so getting the details takes up to 20 seconds. When pressing right, the screen quickly changes to display 'Waiting for torrent state', but then after a second or less, the view switches back to the torrent overview screen. This is where your fix changes things: previously I could navigate the overview screen as normal, but now I cannot unless I press q or left. In that case I can continue to use the overview screen, including request detail views of the same or a different torrent, until the requested detail view is ready and appears.

This is very clearly a bug for me, but considering my slightly odd setup, I would understand it if you closed this bug as a 'cannot reproduce'. I would then re-open it if I found any more information on how to reproduce and/or fix this.

Thanks, Tom

comment:5 Changed 7 years ago by nick

Okay, I think I tracked this down. Could you try again on the latest master and let me know if things behave better? When you hit right there will be a delay before anything happens and then once the component stops properly it should move into details mode.

comment:6 Changed 6 years ago by Cas

  • Status changed from new to pending

comment:7 Changed 6 years ago by nogare

  • Cc mail.nogare@… added
  • Priority changed from minor to major
  • Summary changed from Inconsistent behaviour on slow 'detail view' load to Alltorrent.py sometimes loading over diffrent mode

This bug still occurs, but in more places then reported originally.

Alltorrents->Legacy

When switching to legacy mode the UI for the old console will display, then [on average] after 5-10 seconds, alltorrents is drawn over the legacy UI. If you input a command it will execute and proper UI(legacy's) will appear. (e.g I type info salt the old legacy UI appear on the screen as it should, but after a couple seconds Alltorrents is drawn over top and I can no longer see the legacy UI.

Alltorrents->Preferences

Sometimes it will start to load, (you see a flicker) then [immediately] you're switched back to a alltorrents screen which is usable(i.e you can scroll the lists).

Alltorrents->Eventview

Usually within 4 seconds of hitting 'e', and seeing the string about no events, alltorrents is drawn over top. The interesting thing is that in this case, the alltorrents 'Gui' is not interactive(i.e you can't scroll the overview up and down, till you exit eventview by pressing esc or 'q')

Alltorrents->TorrentDetails?

You see waiting for torrent state, then it usually return to alltorrents and as karaken12 said "sometimes the view switches back to the main view temporarily, until the state is loaded, and sometimes it switches back permanently"

Two things I found interesting: If you mark a torrent, switch to legacy, then run gui... all previously marked torrents will be marked again(is this a indication that alltorrents isn't stopping properly?) 2) during testing while in 'legacy'[the alltorrents UI was drawn over top :( ] the remove-torrent dialog, which I had executed previous to entering legacy finally drew to the screen.

Reproduction: git master and developer install with a couple thousand torrents Note: all the things I listed happen around 40% of the time

comment:8 Changed 6 years ago by nogare

And update on this. It appears that eventually AllTorrents? is shutdown and you can use the new mode. So the way to fix this might be: 1) figure out how to shutdown AllTorrents? quicker
or

2) Figure out how to stop AllTorrents? from drawing to the 'screen', while we shut it down

comment:9 Changed 5 years ago by asmageddon

Fixed in master by merge of my branch. Still happens although extremely rarely(2 cases in ~2 months of testing, one of which flickered back to normal immediately). Completely fixing it is most likely impossible and further reducing frequency would require thrashing the code which is not worth it.

Still not closing it because I'm not sure if I should. Close it if you conclude this as fixed or I'll do it after consulting with someone on the IRC.

comment:10 Changed 5 years ago by asmageddon

  • Resolution set to fixed
  • Status changed from pending to closed

Closing.

comment:11 Changed 7 months ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.