Opened 6 years ago

Closed 6 years ago

#1961 closed bug (Fixed)

Filter for Labels plugin needs 'All' option

Reported by: mathprod Owned by: damoxc
Priority: critical Milestone: 1.3.4
Component: Web UI Version: 1.3.3
Keywords: webui label plugin Cc: mathieu@…

Description

Once the "Label" plugin is activated it seems impossible to reset the filter, even by selecting "State->All" (this action only show all the torrent of the previously selected label). To reset the view I need to logout-login and it's not very handy.

Besides this "filter bug", the first time I have activated this plugin, there was a "label" column in the torrent list, and this column has disappeared since the first logout (the daemon and the webui have been restarted since this time).

Change History (4)

comment:1 Changed 6 years ago by Cas

  • Milestone set to 1.3.4
  • Priority changed from minor to critical
  • Summary changed from [webui] Label plugin & filter reset to Filters for Trackers & Labels need 'All' option

Both the Label and Tracker filter need an 'All' option to reset the filter.

Additional, while in that piece of code, the text label should match gtkui so 'Tracker Host' -> 'Trackers'

I have not seen any issue with the label column disappearing, is this still the case?

comment:2 Changed 6 years ago by mathprod

I didn't manage to reproduce the label column disappearance issue. It was probably related to my not-yet-stable setup, subsequent to the multiple restarts of the daemon and changes of the activated plugins. It's maybe a real bug but rare and visibly not critical...

comment:3 Changed 6 years ago by mathroc

  • Cc mathieu@… added

comment:4 Changed 6 years ago by Cas

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Filters for Trackers & Labels need 'All' option to Filter for Labels plugin needs 'All' option

Fix applied to 1.3-stable: 39f6486

Note: See TracTickets for help on using tickets.