Opened 6 years ago

Closed 6 years ago

#2035 closed bug (Fixed)

[Label] setting label 'move on completed' may fail with web ui

Reported by: mathroc Owned by: damoxc
Priority: minor Milestone: 1.3.4
Component: Plugin Version: 1.3.3
Keywords: Cc:

Description

when trying to set a 'move on completed' folder on a new label with the web ui, if I do :

  • right clic on label
  • label options
  • location
  • check 'apply location settings'
  • check 'move completed to'
  • enter folder location
  • OK

the dialog box does not close and the label is not updated, instead I have to :

  • right clic on label
  • label options
  • location
  • check 'apply location settings'
  • OK
  • right clic on label
  • label options
  • location
  • check 'move completed to'
  • enter folder location
  • OK

and now the label is updated

Change History (4)

comment:1 Changed 6 years ago by mathroc

  • Component changed from other to webui
  • Owner set to damoxc

comment:2 Changed 6 years ago by Cas

  • Component changed from webui to plugin
  • Milestone changed from Future to 1.3.4
  • Summary changed from setting label 'move on completed' may fail with web ui to [Label] setting label 'move on completed' may fail with web ui
  • Version changed from other (please specify) to 1.3.3

comment:3 Changed 6 years ago by bobbyrward

This is caused by the auto_add_trackers being empty. If it's empty, it's an array with 0 items for whatever reason.

https://github.com/bobbyrward/deluge/commit/0522274f5c40bf8f39b5fcac1512817535d7b78d

comment:4 Changed 6 years ago by Cas

  • Resolution set to fixed
  • Status changed from new to closed

Fixed 1.3-stable: a35937454

Note: See TracTickets for help on using tickets.