Opened 5 years ago

Last modified 4 years ago

#2155 reopened bug

Opera unable to add a torrent file

Reported by: devroute Owned by: damoxc
Priority: major Milestone: 1.3.6
Component: Web UI Version: 1.3.5
Keywords: Cc: johnnyg

Description

When you enable https on deluge webui and go to https://ip:port in opera and go to add a torrent in the space below it doesn't show any of the file names and doesn't let you add the torrent it works fine in firefox just not opera thread url below for the issue http://forum.deluge-torrent.org/viewtopic.php?f=12&t=40913

Change History (7)

comment:1 Changed 5 years ago by Cas

  • Cc johnnyg added
  • Component changed from other to webui
  • Milestone changed from Future to 1.3.6
  • Owner set to damoxc
  • Summary changed from Deluge WebUi bugged with opera to Opera unable to add a torrent with https enabled
  • Version changed from other (please specify) to 1.3.5

comment:2 Changed 5 years ago by Cas

  • Resolution set to worksforme
  • Status changed from new to closed

I have tested adding torrents using https webui with Opera 12.11 on Ubuntu along with Opera 12.11 (and 12.02) on XP and cannot replicate.

If you still having issues reopen the ticket with extra details.

comment:3 Changed 4 years ago by johnnyg

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Opera unable to add a torrent with https enabled to Opera unable to add a torrent file

I'm still experiencing this however I've made some head way on why it's failing (it seems to be due to the file upload failing) so I should hopefully have a fix out soon.

Also I don't think this problem is exclusive to https.

comment:4 Changed 4 years ago by johnnyg

  • Resolution set to worksforme
  • Status changed from reopened to closed

Actually never mind; it's failing in Opera Next 12.12 (1662) however it seems to work fine in Opera 12.11 so I'm guessing this is an Opera bug.

In Opera 12.12 it was silently failing to upload the torrent (for unknown reasons). I've fixed this so that it at least now tells you that it failed: http://git.deluge-torrent.org/deluge/commit/?h=1.3-stable&id=ce4b4ef48e6903cfcf60f3895eb44ecb566a05f9

If the bug is still present in Opera 12.12 when it goes final then you will get an error saying that the torrent failed to upload and you can re-open this ticket.

comment:5 Changed 4 years ago by t0ken

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Unfortunately I still have this problem, running 1.3.6 (on a FreeBSD server) with Opera 12.15 on FreeBSD 8-STABLE as well as Arch Linux. All other browsers don't seem to have this problem. I've not tried on Windows (Opera, I do recall using Chromium to add a file on Windows however).

I've tried both with HTTPS enabled and disabled. Is there a way I can help you devs gather information? Perhaps some specific output from Dragonfly (Opera's [superior] answer to firebug)?

Should I open a new bug? Sorry, just realized this was for 1.3.5.

comment:6 Changed 4 years ago by Cas

Can you be more specific about what issue you are seeing and are there any error popups or log messages?

comment:7 Changed 4 years ago by johnnyg

It looks as if the bug I was experiencing in 12.12 is indeed present in 12.15 as I'm able to reproduce this with Opera 12.15 (on Archlinux).

Cas, it's displaying the pop up I added 6 months ago which means the upload is failing which makes me think that the version of extjs doesn't support file uploads in Opera > 12.11.

I would be able to say for sure that was the case if this example also didn't work in Opera 12.15: http://dev.sencha.com/deploy/ext-3.4.0/examples/form/file-upload.html however that doesn't seem to work in any browser I've tried in linux...

Note: See TracTickets for help on using tickets.