Opened 5 years ago

Closed 5 years ago

#2199 closed bug (Invalid)

After sleep Deluge doesn't accept incoming connections anymore

Reported by: WillyWolly Owned by:
Priority: critical Milestone: not applicable
Component: libtorrent Version: 1.3.5
Keywords: Cc:

Description

When I suspend my system (Windows 7 x64), using eigher sleep or hibernate, upon waking the system the "test active port" test for incoming connections fails consistently. Restarting Deluge resolves it.

This might be exclusive to Windows though, or libtorrent's win32 implementation.

This is unrelated to UPnP - I have it disabled and use manual port forwarding (note that there is another problem with Windows sleep and UPnP).

I'd like to hear if anyone else has this problem or if it's caused by something else in my setup.

Change History (2)

comment:1 Changed 5 years ago by Cas

  • Component changed from other to libtorrent
  • Milestone changed from Future to not applicable

Pretty certain this will be a libtorrent issue.

Do you have a range of incoming ports?

comment:2 Changed 5 years ago by WillyWolly

  • Resolution set to invalid
  • Status changed from new to closed

For some reason, under a new install with Windows 8, I don't have this problem any longer. I will reopen this if necessary.

Note: See TracTickets for help on using tickets.