Opened 5 years ago

Closed 17 months ago

Last modified 15 months ago

#2293 closed bug (Fixed)

Unable to right-click in sidebar in classic mode running webui plugin

Reported by: Cas Owned by: damoxc
Priority: minor Milestone: 1.3.13
Component: Web UI Version: 1.3.6
Keywords: Cc:

Description

This bug means that you are unable to create/remove labels.

Not sure if this is a label plugin or webui issue.

Running deluged with webui plugin or deluge-web does not exhibit any problems.

Change History (5)

comment:1 Changed 3 years ago by bro

Can't reproduce on stable-1.3 (tag deluge-1.3.9)

comment:2 Changed 2 years ago by Cas

  • Resolution set to WorksForMe
  • Status changed from new to closed

Weirdly I can't replicate it either, I'll close for now then.

comment:3 Changed 17 months ago by Cas

  • Milestone changed from 1.3.x to 2.0
  • Resolution WorksForMe deleted
  • Status changed from closed to reopened

I finally encountered this issue again and worked out that it was caused by WebUi? plugin being loaded after other plugins...

I can't quickly/easily backport the fix to 1.3 so the workaround is to ensure that in core.conf, WebUi is placed first.

comment:4 Changed 17 months ago by Cas

  • Resolution set to Fixed
  • Status changed from reopened to closed

Fixed in develop: [42e5876ebe3f237a]

comment:5 Changed 15 months ago by Cas

  • Milestone changed from 2.0 to 1.3.13

Fixed in 1.3-stable: [492ad07965]

Note: See TracTickets for help on using tickets.