Opened 4 years ago

Closed 4 years ago

#2365 closed bug (Fixed)

Hiding Progress column generates TypeError

Reported by: ernobe Owned by: Cas
Priority: trivial Milestone: 1.3.7
Component: GTK UI Version: 1.3.6
Keywords: Python TypeError Cc:

Description (last modified by Cas)

start of error message:

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/deluge-1.3.6-py2.7.egg/deluge/ui/gtkui/torrentview.py", line 158, in cell_data_progress
    textstr = textstr + " %.2f%%" % value
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

This appears repeatedly on the commandline after the command deluge -u gtk. It does not appear in deluge logs.

It appears only if the progress column is hidden the last time the program is run. No error messages appear if the progress column is left visible.

Change History (8)

comment:1 Changed 4 years ago by Cas

  • Description modified (diff)

comment:2 Changed 4 years ago by Cas

  • Summary changed from Type error reported by Python ( does not appear in Deluge log ) to Hiding Progress column generates TypeError

comment:3 Changed 4 years ago by Cas

  • Owner changed from ernobe to Cas
  • Status changed from new to assigned

comment:4 Changed 4 years ago by ernobe

  • Resolution set to Invalid
  • Status changed from assigned to closed

I'd like to report that the problem is fixed.

I was following instructions in the DEPENDS file in the 1.3.6 tarball and not installing the boost program or ssl which it says are required to build libtorrent. Now that I've built libtorrent, I can report that the only thing that I did different this time on a fresh install of the tarball was having those programs installed.

comment:5 Changed 4 years ago by ernobe

  • Resolution Invalid deleted
  • Status changed from closed to reopened

Houston we have a problem.

I ran deluge-gtk instead of deluge -u gtk

The problem is still there as before.

comment:6 Changed 4 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.7
  • Status changed from reopened to accepted

Yes it is a bug in 1.3.6 and this is probable fix:

@@ -155,7 +155,7 @@
     textstr = _t(state_str)
     if state_str != "Seeding" and value < 100:
-        textstr = textstr + " %.2f%%" % value
+        textstr = "%s %.2f%%" % (textstr, value)
     if cell.get_property("text") != textstr:
         cell.set_property("text", textstr)

comment:7 Changed 4 years ago by Cas

Fixed 1.3-stable: [a3806b6d7]

comment:8 Changed 4 years ago by Cas

  • Resolution set to Fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.