Opened 4 years ago

Closed 3 years ago

#2369 closed bug (Fixed)

Opening a .torrent file or magnet link bypasses password protection

Reported by: desadoc Owned by: Cas
Priority: major Milestone: 1.3.7
Component: GTK UI Version: 1.3.6
Keywords: Cc:

Description

Im using deluge 1.3.6 on windows 7 ultimate x64. Deluge doesn't ask for password when I open .torrent files or click magnet links.

Sorry for my english or if I didn't created this ticket properly.

Change History (4)

comment:1 Changed 4 years ago by Cas

  • Milestone changed from Future to 1.3.x

comment:2 Changed 4 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.7
  • Owner set to Cas
  • Status changed from new to assigned

I see the problem is in the IPC call bypassing the systray password check

comment:3 Changed 3 years ago by Cas

Duplicate ticket with similar issue: #2458

comment:4 Changed 3 years ago by Cas

  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed in 1.3-stable: [c5ad5589d] & [176064b52]

Note: See TracTickets for help on using tickets.