Opened 2 years ago

Closed 7 months ago

#2774 closed bug (WorksForMe)

Deluge wont start when run from .desktop or commandline

Reported by: bugmenot Owned by:
Priority: major Milestone: needs verified
Component: GTK UI Version: 1.3.12
Keywords: Cc:

Description (last modified by Cas)

OS: Arch using latest server and client with webinterface

Webinterface works

Client will open up but not load anything and hang

Error from commandline

% deluge
/usr/lib/python2.7/site-packages/deluge/ui/gtkui/listview.py:250: GtkWarning: gtk_tree_model_sort_set_sort_column_id: assertion 'header != NULL' failed
  self.treeview.get_model().set_sort_column_id(column_state.sort, column_state.sort_order)

Attachments (4)

hangs.log (18.3 KB) - added by bugmenot 2 years ago.
Debug level log of when it hangs.
hangs.2.log (18.3 KB) - added by bugmenot 2 years ago.
Debug level log of when it hangs.
worked.log (25.4 KB) - added by bugmenot 2 years ago.
Debug level log of when it works normally.
test.log (18.2 KB) - added by bugmenot 2 years ago.
Pieces plugin disabled

Download all attachments as: .zip

Change History (11)

comment:2 Changed 2 years ago by Cas

  • Component changed from other/unknown to GTK-UI
  • Description modified (diff)
  • Milestone changed from 1.3.13 to needs verified
  • Status changed from new to pending

That is a warning, not an error and a GtkWarning should not prevent it loading.

We need details on how to replicate, as per Contributing/BugReporting please include logs and try with a fresh config.

Changed 2 years ago by bugmenot

Debug level log of when it hangs.

comment:3 Changed 2 years ago by bugmenot

  • Status changed from pending to new

Attachment (hangs.log) added by ticket reporter.

Changed 2 years ago by bugmenot

Debug level log of when it hangs.

Changed 2 years ago by bugmenot

Debug level log of when it works normally.

comment:4 Changed 2 years ago by bugmenot

Client: 1.3.12 Server: 1.3.12

libtorrent: 1.0.6.0

Operating System and version. Arch latest Browser and version (if using WebUI). Firefox

Plugins enabled.

Installation method i.e. from source, package or installer.

pacman -S deluge

Precise steps to reproduce the bug.

3/4 times it will hang and result in having to force close it.

1/4 times it will work without a issue and I have included a clean open log to compare

Steps run "deluge-gtk -L debug -l ~/test.log" Wait 5 seconds click connect to localhost daemon, see if it hangs or not.

If it hangs close via task manager

If it connects continue to manage torrents.

WebUI works no matter what happens to deluge-gtk

Both log files included.

comment:5 Changed 2 years ago by Cas

Have you tried without any plugins enabled, for example pieces plugin since the logs stop when it is enabled.

comment:6 Changed 2 years ago by bugmenot

This is the log file with pieces plugin disabled.

Changed 2 years ago by bugmenot

Pieces plugin disabled

comment:7 Changed 7 months ago by Cas

  • Resolution set to WorksForMe
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.