Opened 2 years ago

Closed 2 years ago

#2780 closed bug (Invalid)

Deluge doesn't check downloaded torrent

Reported by: azroach Owned by:
Priority: minor Milestone: needs verified
Component: Unknown Version: other (please specify)
Keywords: check, recheck Cc:

Description

After downloading a torrent, then saving the file/directory and then removing the torrent from Deluge, and then waiting a day or more then trying to add that same torrent through magnet link, Deluge does not check to see if that file has been downloaded.

It just stays stuck on "Downloading 0.00%"

---

DELUGE VERSION: 1.3.12 (i'm not sure how to find libtorrent version since i'm running windows) Windows 10 64-bit version 1511 build 10586.14 No plugins enabled Installation method from installer

Change History (8)

comment:1 Changed 2 years ago by Cas

  • Resolution set to Invalid
  • Status changed from new to closed

If you had added via a torrent file it would recheck the data. As you are using a magnet it is likely waiting to download the metadata from peers, you call tell by the lack of files listed in the files tab. Without the metadata from peers a magnet uri is useless.

How to get the libtorrent version is simple: http://dev.deluge-torrent.org/wiki/Troubleshooting#libtorrentversion

comment:2 Changed 2 years ago by azroach

  • Resolution Invalid deleted
  • Status changed from closed to reopened

I removed the torrent from deluge and then opened a magnet link for it and it rechecked the torrent.

This worked the first day. But after removing it and then waiting a day or more it won't recheck the torrent.

So why does it recheck from magnet link the first day but not the next?

comment:3 Changed 2 years ago by Cas

  • Resolution set to Invalid
  • Status changed from reopened to closed

I have already explained about magnet uris, if the peers (with the metadata) are there one day it will work but if they are gone the next there is nothing any torrent client can do about that. There is a good discussion on reddit about this: https://www.reddit.com/r/techsupport/comments/udcqd/why_dont_magnet_links_show_the_torrents_contents/

comment:4 Changed 2 years ago by azroach

there were no peers the first day. and after i removed the torrent in deluge and then used the magnet link for it to add it again it rechecked the torrent and there were no peers.

Last edited 2 years ago by azroach (previous) (diff)

comment:5 Changed 2 years ago by azroach

  • Resolution Invalid deleted
  • Status changed from closed to reopened

comment:6 Changed 2 years ago by azroach

there's no torrent file available for the torrent any longer. it's just available with a magnet.

so if there's no torrent file available, and it's only available with magnet link, does that mean no one can download it?

Last edited 2 years ago by azroach (previous) (diff)

comment:7 Changed 2 years ago by thepace

Maybe deluge should provide different explanation of whats going until it gets needed data for magnet torrents. something like: getting torrent information including file list and other needed data in place of tracker status message. and show status checking instead of downloading ( i know this is completely false but noob friendly)

this way non experienced users can better understand whats going on.

comment:8 Changed 2 years ago by Cas

  • Resolution set to Invalid
  • Status changed from reopened to closed

This is not the place for discussion, please leave this ticket closed and continue in the forum if you want to discuss it further, there is no issue with Deluge here.

Note: See TracTickets for help on using tickets.