Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#2843 closed bug (Duplicate)

Started Crashing after about a week

Reported by: pearled-duck Owned by:
Priority: major Milestone: needs verified
Component: Unknown Version: 1.3.12
Keywords: hard crash Cc:

Description

When I first installed Deluge and loaded some existing torrents I had plus some new ones, it ran without any issues for a week or so.

Then it crashed for no apparent reason.

After that, it started crashing repeatedly after running for about 30-45 minutes each time.

Removing one large torrent - 128.2 gig - that hadn't yet completed, helped some.

It seemed like it was crashing at some point while checking the existing files for status/resume point.

After that, it started checking another smaller torrent instead, which seemed to be able to complete, and then run for a while before crashing.

I tried running deluge-debug in 'error' mode and then 'warning' and "info" modes with nothing seeming to be reported.

Finally I ran it in "debug" mode which produced a lot of about 2 meg. Hopefully that will be useful.

The Windows crash report is pretty much always exactly this (I've gotten the same exact report several times, but occasionally it's different):

"this application has requested the runtime to terminate it in an unusual way."

Problem signature:

Problem Event Name: APPCRASH Application Name: deluge.exe Application Version: 1.3.12.0 Application Timestamp: 55f580e6 Fault Module Name: libglib-2.0-0.dll Fault Module Version: 2.28.8.0 Fault Module Timestamp: 4e253544 Exception Code: 40000015 Exception Offset: 0004c2d8 OS Version: 6.1.7601.2.1.0.256.48 Locale ID: 1033 Additional Information 1: 23b5 Additional Information 2: 23b5881e04da4601eeb5fe20de0ee544 Additional Information 3: c73c Additional Information 4: c73c680d3607b7a1b1a07211496b5c4e

In addition, when running deluge-debug from Command Prompt, additional messages are shown there which might be of use:

Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Kerry>cd\program files (x86)

C:\Program Files (x86)>cd deluge

C:\Program Files (x86)\Deluge>deluge-debug.exe -L debug -l "%UserProfile?%\deskto p\Deluge.log" c:\program files (x86)\deluge\deluge-1.3.12-py2.6.egg\deluge\ui\gtkui\listview.p y:250: GtkWarning?: gtk_tree_model_sort_set_sort_column_id: assertion `header != NULL' failed C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: gdkgc-win32.c:830: SaveDC failed: The operation completed successfully.

C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: gdkgc-win32.c:970: RestoreDC failed: The operation completed successful ly. C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: gdkdrawable-win32.c:1873: GetDC failed: The operation completed success fully. C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: gdkgc-win32.c:968: GetCurrentObject? failed: The handle is invalid. C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: gdkgc-win32.c:970: RestoreDC failed: The handle is invalid. C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: _gdk_win32_drawable_release_dc: assertion `impl->hdc_count > 0' failed C:\Program Files (x86)\Deluge\library.zip\twisted\internet\_glibbase.py:375: Gtk Warning: gdkpixmap-win32.c:279: CreateDIBSection failed: The parameter is incorr ect. Gdk:ERROR:gdkdrawable-win32.c:2040:_gdk_win32_drawable_finish: assertion failed:

(impl->hdc_count == 0)

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

Change History (8)

comment:1 Changed 20 months ago by pearled-duck

The log file in "debug" mode is about 2 meg, which is too large to attach. Let me know where I can send it via email/attachment.

comment:2 Changed 20 months ago by Cas

  • Resolution set to Duplicate
  • Status changed from new to closed

This is a duplicate of #1454 and the only workaround is to not leave the Gtk UI running for extended periods which can be achieved by using Deluge in thinclient mode so the daemon runs in the background and you connect with the Gtk client, therefore crashes therefore won't affect torrents.

I have noticed someone has packaged a 64-bit version of GTK2 so it might be possible to produce a test build to see if that fixes the issues as it's a later version: 2.24.30.

comment:3 Changed 20 months ago by pearled-duck

I don't have that option, as I'm using the Windows version and am not a Linux wizard.

Why would it take a week or two to crash the first time, and then crash after less than an hour every time after that, even following a system restart?

If it's a cumulative time thing, wouldn't it start crashing after a week or two of Gtk UI uptime regardless? That still seems like something that needs to be fixed.

And, how about someone putting together that test build so I can see if it helps?

comment:4 follow-up: Changed 20 months ago by Cas

You can use thinclient setup locally on Windows, just untick classic mode and start the daemon!

comment:5 in reply to: ↑ 4 Changed 20 months ago by pearled-duck

Replying to Cas:

You can use thinclient setup locally on Windows, just untick classic mode and start the daemon!

I've been programming since 1973, but would it be considered rude to point out that this isn't really a long-term solution?

And I wouldn't mind trying a test build using that newer 64-bit package mentioned.

comment:6 Changed 20 months ago by pearled-duck

Does just unticking the Classic mode automatically start the daemon, or do I have to do that separately? The message says I have to restart the GUI but nothing about the daemon.

Does restarting Deluge (graphic mode) after that, start the daemon too, and then I can close the GUI while the daemon continues to run?

As I said, I'm not a Linux user.

comment:7 follow-up: Changed 20 months ago by Cas

With all your programming experience I shouldn't have to explain anything then. The reasons are all documented in the other ticket, details on thinclient and building from source are also documented.

http://dev.deluge-torrent.org/wiki/UserGuide

It has nothing at all to do with Linux specifically, it's basic computing concepts.

comment:8 in reply to: ↑ 7 Changed 20 months ago by pearled-duck

Background processes including daemons have to be started by something else. But Linux/bsd users seem used to the idea of starting them separately/manually. My business software always started background processes in order to free up the user's terminal to do something else, while the updating of files etc. took place in background. Nobody went to a command line/prompt to start that happening.

To extend that example, would be that unchecking the "Classic" option in the Deluge gui would do something like ask "Do you want to start the background daemon now and continue?" etc.

And that's mostly the point, really. Deluge users shouldn't have to know (almost) as much as the developers in order to be able to use it effectively.

And the user guide doesn't reflect the still apparent reality that, well folks, you kinda HAVE TO use thin client or else it crashes all the time. Because of a five-year-old bug that isn't quite fixed yet.

It's far from comprehensive, too. For one thing, it's all written from the perspective of initial installation and use. But I've already been using Deluge for a couple weeks. So, do I still need to: "Create Default Config

To create the config directory and populate with the default files, run and then stop deluged."

My guess would be no, but the user guide doesn't tell me that.

And further, "killall" is very much Linux not windows.

And "Note: The config location is either the default location with reference to the user that deluged is running as." is grammatically incomplete. Using "either" means you need an "or" clause.

Moving on... Once again, since I've already been using Deluge for a couple weeks, am I already an "authorized user" in the "auth" file? Seems like I should be, but there's no information on that in the user guide.

And if you can look at the rest of the user guide page(s) and tell me that's not all about Linux rather than Windows... well, maybe you'd like to buy a bridge or some swamp land or something.

Windows users should probably just be directed down to the GTK UI section, if not moved to another page entirely to avoid the Linux gibberish.

And I found that I didn't have to do hardly any of that stuff which also appears to be for first-time installation.

Good thing I didn't waste my time on it.

Maybe you should add a section for "switching to thin client mode after already having installed and used Deluge." There's a lot less to it than the user guide seems to indicate.

Last edited 20 months ago by pearled-duck (previous) (diff)
Note: See TracTickets for help on using tickets.