#2961 closed bug (Fixed)

[LIBTORRENT] Deluged Error No Converter Found

Reported by: Doadin Owned by:
Priority: critical Milestone: not applicable
Component: libtorrent Version: develop (git)
Keywords: Cc:

Description

tested on deluge develop commit a7826c4f90115026d3d50c51f9b3a4e5520d9ccf and libtorrent RC_1_1 commit 132be5101ff48ecc2831e4171c4f2043b290c6f9

alertmanager.py", line 99, in handle_alerts

alerts = self.session.pop_alerts()

exceptions.TypeError?: No to_python (by-value) converter found for C++ type: class boost::shared_ptr<class libtorrent::alert>

Change History (7)

comment:1 Changed 12 months ago by Doadin

This is due to a change that makes libtorrent incompatible with older boost versions. not sure if this is something we can change or should or should report to them?

comment:2 Changed 12 months ago by Cas

I'm not sure what you are talking about. Can you provide the full trace please and what incompatibility?

comment:3 Changed 12 months ago by Doadin

Building libtorrent with boost 1.59 yields this result. the incompatibility is like i said with older boost versions eg. 1.59.( compiling libtorrent with boost 1.59 error with boost 1.63.0 no error.)

From what i understand of it here: https://github.com/arvidn/libtorrent/blob/RC_1_1/bindings/python/src/converters.cpp#L85 is a list of defined conversions defined by libtorrent. Now boost has it own set defined by default. A change in 1.1.x (RC_1_1) has introduced a change that uses a new type but doesn't add the needed converter for compatibility with older boost versions however newer versions of boost eg. 1.63.0 has this already defined so is unnecessary.

As a side note it was sometime after https://github.com/arvidn/libtorrent/commit/30303c17dfce4baae84758dd2fc9c93d9165da62 that this issue came about and i suspect https://github.com/arvidn/libtorrent/commit/61c057947c3d9c9285cf4f3bc73644a04d6ab82e to be the reason.

Last edited 12 months ago by Doadin (previous) (diff)

comment:4 follow-up: Changed 12 months ago by Cas

The problem is that I am not seeing any such error here and I have both boost 1.55 and 1.58.

What OS are you using? Is there a quick way to replicate?

It would be helpful if you can confirm that is the commit that is at issue?

This is a libtorrent/boost issue so can report your findings upstream.

comment:5 in reply to: ↑ 4 Changed 12 months ago by Doadin

Replying to Cas:

The problem is that I am not seeing any such error here and I have both boost 1.55 and 1.58.

What OS are you using? Is there a quick way to replicate?

It would be helpful if you can confirm that is the commit that is at issue?

This is a libtorrent/boost issue so can report your findings upstream.

Hmm. Well I am running windows 10 for my main system and windows 7 w/jenkins for my build system. Which both have had the issue on any build i make with boost 1.59 since 12-12-2016. I have made monthly(sometimes more) builds for a while now. Maybe try boost 1.59 maybe its version specific? All i know it since 12-12-2016 every build i made with the same system the same exact way(automated through jenkins) they would never work. Then i change to 1.63 and all the sudden no error. So i mean just make a build of libtorrent on windows with boost 1.59 and libtorrent branch RC_1_1 and start deluge it should give the error.

Let me know if you test what your results are or if you open a ticket with libtorrent.

Last edited 12 months ago by Doadin (previous) (diff)

comment:6 Changed 12 months ago by Cas

Well std_pointer was introduced in 1.63 so that likely 'fixed' the issue. I wonder if it's a windows compiler related.

Created a ticket: https://github.com/arvidn/libtorrent/issues/1667

comment:7 Changed 10 months ago by Cas

  • Milestone changed from 2.0 to not applicable
  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.