Opened 11 months ago

Closed 11 months ago

Last modified 10 months ago

#2988 closed bug (Invalid)

Failures due to "ImportError: /usr/lib/python2.7/dist-packages/libtorrent.so: ..." don't causes initd unit to crash

Reported by: krichter Owned by:
Priority: minor Milestone: needs verified
Component: Core Version: 1.3.14
Keywords: Cc:

Description

Failures due to ImportErrors in the form of ImportError: /usr/lib/python2.7/dist-packages/libtorrent.so: [...], like reported in #2950 don't cause the initd unit to crash, i.e. sudo systemctl status deluged.service reports

Mär 08 15:05:30 richtercloud.de systemd[1]: Starting LSB: Start or stop the Deluge BitTorrent daemon....
Mär 08 15:05:31 richtercloud.de deluged[6293]:  * Starting Deluge BitTorrent Daemon deluged
Mär 08 15:05:31 richtercloud.de deluged[6293]:    ...done.
Mär 08 15:05:31 richtercloud.de systemd[1]: Started LSB: Start or stop the Deluge BitTorrent daemon..

and status active (exited) whereas the log contains

[ERROR   ] 15:05:34 main:248 /usr/lib/python2.7/dist-packages/libtorrent.so: undefined symbol: _ZNK10libtorrent14announce_entry12can_announceENSt6chrono10time_pointINS1_3_V212system_clockENS1_8durationIlSt5ratioILl1ELl1000000000EEEEEEb
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/deluge/main.py", line 241, in start_daemon
    Daemon(options, args)
  File "/usr/lib/python2.7/dist-packages/deluge/core/daemon.py", line 144, in __init__
    from deluge.core.core import Core
  File "/usr/lib/python2.7/dist-packages/deluge/core/core.py", line 38, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib/python2.7/dist-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
ImportError: /usr/lib/python2.7/dist-packages/libtorrent.so: undefined symbol: _ZNK10libtorrent14announce_entry12can_announceENSt6chrono10time_pointINS1_3_V212system_clockENS1_8durationIlSt5ratioILl1ELl1000000000EEEEEEb

and the process crashed.

Maybe it's time for a systemd unit.

I'm using 1.3.14-0~yakkety~ppa1 from the PPA on Ubuntu 16.10.

Change History (4)

comment:1 Changed 11 months ago by Cas

  • Resolution set to Invalid
  • Status changed from new to closed

There is a systemd unit: http://dev.deluge-torrent.org/wiki/UserGuide/Service/systemd

The maintainers of the official debian/ubuntu deluge packages include an init.d so you will need to ask them to change it.

comment:2 Changed 11 months ago by krichter

There is a systemd unit: ​http://dev.deluge-torrent.org/wiki/UserGuide/Service/systemd

I see, great!

But the initd unit still remains in running state after the failure. It's probably not worth spending too much time on it, though, since systemd has become quite widespread.

comment:3 Changed 11 months ago by Cas

No-one should spend any time fixing them. They were already obsolete when upstart scripts were created and now doubly so.

comment:4 Changed 10 months ago by krichter

The import error was caused by remaining libtorrent-rasterbar.so.9... files in /usr/local/lib from a source installation, so the issue was unrelated to initd and systemd, but a user error.

Switching to the linked systemd units worked smoothly, thank you.

Note: See TracTickets for help on using tickets.