Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#335 closed feature-request (Fixed)

can not connect to ipv6 only tracker

Reported by: pl4nkton@… Owned by: andar
Priority: major Milestone: 1.2.0
Component: Core Version: 1.1.5
Keywords: Cc: leety@…

Description

I tested deluge against this tracker https://www.sixxs.net/tools/tracker/
0.6svn hung with:
"Tracker Status: Announce Sent"

The 0.5.8.9 client says:
Alarm: SixXS IPv6 BitTorrent? Tracker: This tracker only serves IPv6 clients, you are coming from x.x.x.x (HTTP-Code=400, Anzahl in der Reihe=3)

Deluge only send a ipv4 announce.

Change History (11)

comment:1 Changed 6 years ago by andar

  • Milestone set to 1.1.0
  • Version changed from 0.6.0svn to 1.1.0_dev

We will need to have an option to set the listening interface since libtorrent defaults to ipv4 if available.

comment:2 Changed 5 years ago by anonymous

  • Milestone 1.1.0 deleted

Milestone 1.1.0 deleted

comment:3 Changed 5 years ago by a1@…

  • Milestone set to 1.2.0
  • Type changed from bug to feature-request

In 1.1.3 this option is still missing. Is there any way to force deluge to send ipv6 announces?

comment:4 Changed 5 years ago by an anonymous coward

  • Version changed from 1.1.0_dev to 1.1.5

I would like to see this feature too. (currently on 1.1.5)

comment:5 Changed 5 years ago by jankratochvil

With the same sixxs tracker got:

1.1.4
Unhandled exception in thread started by 
terminate called after throwing an instance of 'boost::bad_lexical_cast'
  what():  bad lexical cast: source type value could not be interpreted as target
[ERROR   ] 00:21:06 client:146 Socket or XMLRPC error: (111, 'Connection refused')

comment:6 Changed 5 years ago by Nil Einne <leety@…>

  • Cc leety@… added

Can confirm the same problem as jankratochvil with SixXs? IPv6 only tracker and FreeBSD 7.2 with deluged 1.1.5 (latest version in the FreeBSD ports tree). Also in a highly popular torrent I see not IPv6 peers so I presume it's not working even without IPv6 only tracker. While I haven't yet tested with some other client in this OS, my IPv6 is working including in FreeBSD and I usually get IPv6 peers in Windows.

comment:7 Changed 5 years ago by Nil Einne

Okay further testing the problem does not occur on Windows Vista x64 with either 1.1.5 or 1.1.7. This is with the daemon. SixXs? IPv6 only tracker torrents works fine. On 1.1.5 I had some odd errors for example crashes of the daemon without any error message and at least with SixXs? very slow speed many times. One or twice it went fast but most of the time it seemed very slow. I'm not sure what caused this it may be unrelated. Logging in debug mode doesn't show anything useful that I can see. Also because of the display peers issue it's difficult to tell what the problem is since I noticed some odd behaviour bit I believe it's related to the display peers issue.

So not sure what the problem is on FreeBSD. Has anyone got it working on Linux?

Note that in any case there's no control over the IPv6.

comment:8 Changed 5 years ago by a1@…

Hmm it doesn't work on Linux. Using the Sixxs IPV6 only tracker. When I try to start the torrent file deluge crashes:



[ERROR   ] 11:58:54 client:158 Socket or XMLRPC error: [Errno 111] Connection refused
Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/deluge/ui/gtkui/systemtray.py", line 323, in on_menuitem_quit_activate
    client.shutdown()
  File "/var/lib/python-support/python2.6/deluge/ui/client.py", line 341, in shutdown
    self.core.call("shutdown", None)
  File "/var/lib/python-support/python2.6/deluge/ui/client.py", line 124, in call
    raise deluge.error.NoCoreError("The core proxy is invalid.")
deluge.error.NoCoreError: 'The core proxy is invalid.'

IPV6 itself on my machine (browsing, nntp, smtp etc) works fine

comment:9 Changed 5 years ago by Nil Einne

Hmm so it appears to only be Windows. Well at least I know it's not only FreeBSD because if it was I may have to wait a long while for any action :-(

Anyway in Windows I can confirm it also seems to work with general purpose trackers. E.g. I tried with Piratebay and highly popular file and I saw some IPv6 connections in netstat. However for some reason the peers don't show properly so I can't confirm it is actually transferring or how these peers were found (DHT?).

BTW, in case this wasn't clear I did manage to receive a complete file from SixXs? tracker with Deluge 1.1.7 in Windows.

comment:10 Changed 5 years ago by jankratochvil

With the sixxs.net tracker it works for me now on Fedora-11:
deluge-1.1.9-1.fc11.noarch
rb_libtorrent-0.14.3-2.fc11.x86_64

comment:11 Changed 5 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Great, this ticket will be closed.

Note: See TracTickets for help on using tickets.