Opened 9 years ago

Closed 3 years ago

#733 closed bug (Fixed)

Label plugin broken in web interface

Reported by: algspd@… Owned by: damoxc
Priority: critical Milestone: 1.3
Component: Web UI Version:
Keywords: label web webui add Cc: simon@…

Description

Label plugin is broken in web interface, it allows to configure a label but doesn't allow to add a torrent to a label or to add new labels.

Change History (8)

comment:1 Changed 8 years ago by anonymous

  • Version changed from 1.1.0 to 1.1.9

Steel broken

comment:2 Changed 8 years ago by damoxc

  • Owner changed from mvoncken to damoxc
  • Status changed from new to accepted

comment:3 Changed 8 years ago by damoxc

  • Milestone set to 1.3.0

comment:4 Changed 8 years ago by simonbcn

  • Cc simon@… added

Hi,
I have just installed Deluge 1.2.1 (deluged + deluge-web in server) and I have activated the label plugin in webUI but:

  • It doesn't save the activated status of label plugin in options window (see screen-shot).
  • It activate the label plugin, I see two new tabs in WebUI: "Tracker Host" and "Label". But I can't create labels.

http://i238.photobucket.com/albums/ff28/simonbcn/captura_014.png

comment:5 Changed 8 years ago by simonbcn

I have seen the deluged.log file and it shows this warning:

17:52:48 config:347 Unable to open config file /.../.config/deluge/label.conf: [Errno 2] No existe el fichero ó directorio: '/.../.config/deluge/label.conf'

Who creates that file?

comment:6 Changed 7 years ago by damoxc

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in master.

comment:7 Changed 3 years ago by polygonica

  • Resolution Fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.1.9 to 1.3.6

Bug appears to have reappeared in 1.3.6 (newest FreeBSD port version). Right-clicking a label in the webui does nothing, and when right-clicking a torrent, the ability to add a torrent to a label is missing.

Last edited 3 years ago by polygonica (previous) (diff)

comment:8 Changed 3 years ago by Cas

  • Resolution set to Fixed
  • Status changed from reopened to closed
  • Version 1.3.6 deleted

Please don't reopen a ticket that is very old and not the same issue. There is only one known label plugin issue, in Classic mode, that is here: #2293

Note: See TracTickets for help on using tickets.