Ticket #553: deluge-9999.ebuild

File deluge-9999.ebuild, 1.7 KB (added by danii, 16 years ago)

Gentoo svn ebuild

Line 
1# Copyright 1999-2008 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.14 2008/08/07 10:57:59 armin76 Exp $
4
5inherit eutils distutils subversion flag-o-matic
6
7ESVN_REPO_URI="http://svn.deluge-torrent.org/trunk"
8ESVN_PROJECT="deluge"
9
10DESCRIPTION="BitTorrent client with a client/server model."
11HOMEPAGE="http://deluge-torrent.org/"
12SRC_URI=""
13
14LICENSE="GPL-2"
15SLOT="0"
16KEYWORDS=""
17IUSE="gtk"
18
19DEPEND=">=dev-lang/python-2.3
20 dev-libs/boost
21 dev-python/setuptools"
22RDEPEND="${DEPEND}
23 dev-python/pyxdg
24 dev-python/pygobject
25 gtk? (
26 >=dev-python/pygtk-2
27 dev-python/pyxdg
28 dev-python/dbus-python
29 gnome-base/librsvg
30 )"
31
32pkg_setup() {
33 if ! built_with_use --missing true "dev-libs/boost" threads; then
34 eerror "dev-libs/boost has to be built with threads USE-flag."
35 die "Missing threads USE-flag for dev-libs/boost"
36 fi
37
38 filter-ldflags -Wl,--as-needed
39}
40
41src_install() {
42 distutils_src_install
43 newinitd "${FILESDIR}"/deluged.init deluged
44 newconfd "${FILESDIR}"/deluged.conf deluged
45}
46
47pkg_postinst() {
48 elog
49 elog "If after upgrading it doesn't work, please remove the"
50 elog "'~/.config/deluge' directory and try again, but make a backup"
51 elog "first!"
52 elog
53 einfo "Please note that Deluge is still in it's early stages"
54 einfo "of development. Use it carefully and feel free to submit bugs"
55 einfo "in upstream page."
56 elog
57 elog "To start the daemon either run 'deluged' as user"
58 elog "or modify /etc/conf.d/deluged and run"
59 elog "/etc/init.d/deluged start as root"
60 elog "You can still use deluge the old way"
61 elog
62 elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
63 elog
64}