Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#1035 closed bug (Fixed)

Bug in client authentication when auth file has many lines (patch included)

Reported by: gcoriasco Owned by: andar
Priority: major Milestone: 1.2.0
Component: Core Version: 1.2.0
Keywords: client auth patch Cc:

Description

Hi, I found a problem in authenticating localclient to deluged running on the same host after upgrading to version 1.2.0_rc1 on my Ubuntu machine. The problem is in the fact that the client does not strip out the trailing newline from the password read from the auth file (as server do instead).

I'm attaching a little patch to deluge/ui/common.py that should solve this problem.

I hope this will help

Bye

Giovanni

Attachments (1)

deluge_ui_common.py.diff (501 bytes) - added by gcoriasco 11 years ago.
Patch to deluge/ui/common.py file

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by gcoriasco

Patch to deluge/ui/common.py file

comment:1 Changed 11 years ago by gcoriasco

  • Milestone set to 1.2.0

comment:2 Changed 11 years ago by gcoriasco

  • Component changed from other to core

comment:3 follow-up: Changed 11 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

I believe this has already been fixed in [5826]

comment:4 in reply to: ↑ 3 Changed 11 years ago by gcoriasco

Replying to andar:

I believe this has already been fixed in [5826]

Thank you: this is probably due to the fact that the version I just updated to (1.2.0~rc1-2 from the PPA repo on my Ubuntu Jaunty) does not include that fix yet... I assumed that that was the last... sorry

Thank you

comment:5 Changed 7 years ago by Cas

  • Version changed from 1.2.0_rc1 to 1.2.0
Note: See TracTickets for help on using tickets.