Opened 15 years ago

Closed 15 years ago

#1065 closed bug (Invalid)

spins CPU due to incorrect polling

Reported by: sthalik Owned by: andar
Priority: major Milestone:
Component: GTK UI Version: 1.2.0_rc3
Keywords: Cc:

Description

rc3 spins the CPU due to not polling correctly.

poll([{fd=7, events=POLLIN}, {fd=5, events=POLLIN}, {fd=10, events=POLLIN}, {fd=3, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=13, events=POLLIN}, {fd=4, events=POLLIN}], 8, 18) = 1 ([{fd=9, revents=POLLIN}]) read(10, 0x1b3c8b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)

It's fd 9 that has incoming data and read(2) is called on fd 10.

Change History (1)

comment:1 Changed 15 years ago by damoxc

  • Resolution set to invalid
  • Status changed from new to closed

duplicate of #1064

Note: See TracTickets for help on using tickets.