Opened 13 years ago

Closed 12 years ago

#1066 closed bug (Invalid)

Daemon won't bind incoming ports if listen_interface is defined

Reported by: mariusk Owned by: andar
Priority: minor Milestone:
Component: Core Version: 1.3.1
Keywords: Cc: kevin@…

Description

Machine with public IP on eth0 and tested without firewall. Incoming range: 52000:52049 Outgoing range: 52050:52100

GTK UI says "active port: 0" no matter what I fill in the fields. netstat -ap shows only connections > 52049. I am both seeding and downloading.

Ubuntu 9.10 with deluge ppa, same problem in 9.04 and at least present since 1.2.0rc1. May have been in earlier versions without me noticing.

Attached startup debug log with torrents and IP removed.

Attachments (1)

deluged.log (21.8 KB) - added by mariusk 13 years ago.
Trimmed deluged startup debug log.

Download all attachments as: .zip

Change History (14)

Changed 13 years ago by mariusk

Trimmed deluged startup debug log.

comment:1 Changed 13 years ago by andar

This works for me.

Are you sure nothing else is using those ports? The log provided looks normal and it appears to be setting the proper listen port range.

comment:2 Changed 13 years ago by andar

  • Status changed from new to pending

comment:3 Changed 13 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:4 Changed 12 years ago by dfalk

  • Status changed from closed to reopened
  • Version changed from 1.2.0_rc3 to 1.2.3

The same thing happens to me on 1.2.3. I've checked the port range and nothing else is listening in that range at all.

(Running on Ubuntu server 10.04)

comment:5 follow-up: Changed 12 years ago by damoxc

Could you check 1.3.0rc1 please, 1.2.3 isn't the latest version.

comment:6 in reply to: ↑ 5 Changed 12 years ago by dfalk

Replying to damoxc:

Could you check 1.3.0rc1 please, 1.2.3 isn't the latest version.

I'm using the deluge-ppa on Ubuntu, which is up-to-date. How can I update it to 1.3.0rc1?

Thanks

comment:7 Changed 12 years ago by dfalk

I just figured out how to build from source. I'm now at 1.3.0_rc1. The problem is still there.

comment:8 Changed 12 years ago by thekev

Having the same issue here. Occurs on 1.2.2 and 1.3.1. My range is configured for 52001-52009. Will not use a random port either.

Reproduce:

netstat -nPi4 | grep deluge | grep LISTEN

deluged   32262 kevin    8u  IPv4 19677168      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32262 kevin   24u  IPv4 19679972      0t0  TCP *:9992 (LISTEN)

58846 = Daemon RPC, 9992 = WebUI

Hmm, I just got to thinking... what happens if I remove the 'interface' declaration (set to eth1):

deluged   32262 kevin    8u  IPv4 19677168      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32262 kevin   24u  IPv4 19685133      0t0  TCP *:9992 (LISTEN)
deluged   32262 kevin   34u  IPv4 19685135      0t0  TCP *:52001 (LISTEN)

Well lookie there! How about a random port?

deluged   32262 kevin    8u  IPv4 19677168      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32262 kevin   24u  IPv4 19687214      0t0  TCP *:9992 (LISTEN)
deluged   32262 kevin   34u  IPv4 19687216      0t0  TCP *:59633 (LISTEN)

Ok, now put the interface declaration back in, and go back to port range:

deluged   32262 kevin    8u  IPv4 19677168      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32262 kevin   24u  IPv4 19687986      0t0  TCP *:9992 (LISTEN)
deluged   32262 kevin   34u  IPv4 19687216      0t0  TCP *:59633 (LISTEN)

Nope. Stuck:

deluged   32262 kevin    8u  IPv4 19677168      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32262 kevin   24u  IPv4 19687986      0t0  TCP *:9992 (LISTEN)
deluged   32262 kevin   34u  IPv4 19687216      0t0  TCP *:59633 (LISTEN)

Restart daemon?

deluged   32455 kevin    8u  IPv4 19688448      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32455 kevin   28u  IPv4 19688474      0t0  TCP *:9992 (LISTEN)

Gone. Remove interface, go back to port range, restart daemon:

deluged   32477 kevin    8u  IPv4 19689573      0t0  TCP 127.0.0.1:58846 (LISTEN)
deluged   32477 kevin    9u  IPv4 19689577      0t0  TCP *:52001 (LISTEN)
deluged   32477 kevin   29u  IPv4 19689614      0t0  TCP *:9992 (LISTEN)

BINGO

Workaround: don't specify a listen_interface.

comment:9 Changed 12 years ago by thekev

  • Priority changed from major to minor
  • Summary changed from Deluge won't bind incoming ports to Daemon won't bind incoming ports if listen_interface is defined
  • Version changed from 1.2.3 to 1.3.1

comment:10 Changed 12 years ago by thekev

  • Cc kevin@… added

comment:11 Changed 12 years ago by Cas

  • Status changed from reopened to pending

I see that you mentioned using eth1 but the interface setting should be an ip address.

comment:12 Changed 12 years ago by thekev

Using IP worked. I should have posted back. This is a documentation issue.

comment:13 Changed 12 years ago by Cas

  • Resolution set to invalid
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.