Opened 12 years ago

Closed 12 years ago

#1113 closed feature-request (Fixed)

[PATCH] Don't move storage if while downloading storage was moved already to somewhere else

Reported by: Ideal Owned by:
Priority: minor Milestone: 1.3
Component: Core Version: 1.3.0_dev
Keywords: Cc:

Description

Suppose default download dir ~/dl/incomplete, "move completed" dir ~/dl/.

Sometimes while downloading torrent i can move storage by hand from ~/dl/incomplete to for example ~/movies/. So with current way of how it works - even if i already moved myself storage where i need it to deluge will anyway once again move it from ~/movies/ to "move completed" dir anyway.

This patch adds check so move storage on download completion is done only when download dir of torrent equals to default download dir, in other words - it checks so i didn't move storage myself already where i need it.

Attachments (1)

move-storage.patch (681 bytes) - added by Ideal 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by Ideal

comment:1 Changed 12 years ago by Ideal

Recently i've seen such feature in utorrent, it has "Only move from the default download directory" checkbox in preferences. Is it okay if it'll done this way too in deluge ? I can improve the patch to add such preference.

comment:2 Changed 12 years ago by Ideal

Some more thoughts about this - well, good for utorrent to have that "Only move from the default download directory" preference, but basically i don't see a need for such a preference. As for me its quite obvious that expected behavior will be always with that preference turned on. I don't see for now a need for that preference to ever be turned off, because why do you ever would want to move storage 2 times - first to your some custom directory by hand (while torrent is downloading), and then by deluge second move storage "pass" to "move completed" directory (after download finishes) ?

comment:3 follow-up: Changed 12 years ago by Cas

  • Milestone set to 1.3.0

review patch for adding to master

comment:4 in reply to: ↑ 3 Changed 12 years ago by Ideal

Replying to Cas:

review patch for adding to master

Don't know whether you're speaking to me, but i can say this patch applies and works okay with master..

comment:5 follow-up: Changed 12 years ago by gazpachoking

This patch would prevent move completed from working if you are downloading to anywhere but your default download location. I suggest just disabling move completed for that torrent. Or, alternately, have move completed be automatically disabled for a torrent if the storage is manually moved.

comment:6 in reply to: ↑ 5 Changed 12 years ago by Ideal

Replying to gazpachoking:

This patch would prevent move completed from working if you are downloading to anywhere but your default download location.

Yes, this is essentially what it does. As we speak about this here would be maybe good to have real world examples of use cases when you really need move completed when downloading to not a default location.

I suggest just disabling move completed for that torrent. Or, alternately, have move completed be automatically disabled for a torrent if the storage is manually moved.

As an alternative autodisabling of move storage also would work and patch could be changed to this.

comment:7 Changed 12 years ago by gazpachoking

Real world example this patch would break: TV downloads to /media/drivea/incomplete, moves to /media/drivea/TV. Movies download to /media/driveb/incomplete, moves to /media/driveb/Movies

comment:8 Changed 12 years ago by Ideal

This is with AutoAdd? plugin seems like (or also with it) ? I see..

Okay, any objections to autodisabling of move completed on manual storage move ?

comment:10 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

This has been committed in master.

Note: See TracTickets for help on using tickets.