Opened 11 years ago

Closed 11 years ago

#1196 closed defect (Fixed)

This version of Deluge requires libtorrent >=0.14.5.0

Reported by: marcosgdf Owned by:
Priority: major Milestone: 1.3
Component: Core Version: 1.2.1
Keywords: Cc:

Description

I'm on Ubuntu 9.10, Deluge 1.2.1.2-karmic-ppa1. Since I updated to the ppa version, I can't start Deluge, the following error is shown:

mediacenter@mediacenter-pc:~$ deluged -p 58846 -d
[ERROR   ] 01:12:06 main:216 This version of Deluge requires libtorrent >=0.14.5.0!
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/deluge/main.py", line 209, in start_daemon
    Daemon(options, args)
  File "/usr/lib/pymodules/python2.6/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib/pymodules/python2.6/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib/pymodules/python2.6/deluge/_libtorrent.py", line 60, in <module>
    check_version(lt)
  File "/usr/lib/pymodules/python2.6/deluge/_libtorrent.py", line 53, in check_version
    raise ImportError("This version of Deluge requires libtorrent >=%s!" % REQUIRED_VERSION)
ImportError: This version of Deluge requires libtorrent >=0.14.5.0!

But as I can see in Synaptic Package Manager, I have got python-libtorrent (0.14.10.2-karmit-ppa1), libtorrent-rasterbar5 (0.14.10-2-karmic-ppa) installed, so I don't know why does Deluge says that I have an old version

Change History (4)

comment:1 Changed 11 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

This has been fixed and the fix should be in 1.2.2.

comment:2 Changed 11 years ago by marcosgdf

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm using Deluge 1.2.1.2-karmic-ppa1, so I suppose that it is not fixed (yet).

Regards, marcos.

comment:3 Changed 11 years ago by squisher

Note that the updated 1.2.2 package is in the process of getting built. Waiting a couple of hours and then upgrading will fix this issue.

comment:4 Changed 11 years ago by marcosgdf

  • Resolution set to fixed
  • Status changed from reopened to closed

Sorry, I was wrong. I'll wait and try to upgrade tomorrow my deluge installation.

Thanks and apologies.

Note: See TracTickets for help on using tickets.