Opened 8 years ago

Closed 8 years ago

Last modified 10 months ago

#1199 closed bug (Fixed)

deluge 1.2.2 considers 0.14.9 > 0.14.10

Reported by: simonbcn Owned by:
Priority: blocker Milestone: 2.x
Component: Core Version: 1.2.1
Keywords: Cc:

Description

I have built deluge 1.2.2 and libtorrent-0.14.10 from source.
But when I execute deluged, it shows this error and it doesn't start:

[ERROR   ] 16:21:31 main:216 This version of Deluge requires libtorrent >=0.14.9.0!
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/main.py", line 209, in start_daemon
    Daemon(options, args)
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/_libtorrent.py", line 60, in <module>
    check_version(lt)
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/_libtorrent.py", line 53, in check_version
    raise ImportError("This version of Deluge requires libtorrent >=%s!" % REQUIRED_VERSION)
ImportError: This version of Deluge requires libtorrent >=0.14.9.0!

Change History (6)

comment:1 Changed 8 years ago by damoxc

  • Resolution set to invalid
  • Status changed from new to closed

Heh, this is about the third time this has been reported. Check to see if a ticket already exists before reporting please.

Duplicate of #1196 and #1197

comment:2 Changed 8 years ago by simonbcn

  • Resolution invalid deleted
  • Status changed from closed to reopened

It's no same error. In both cases they speaks about deb packages. My problem is building form sources.

comment:3 Changed 8 years ago by damoxc

Ah my mistake. I just remembered seeing the commit email with the diff that fixed it. It was fixed post 1.2.2, you can grab an up to date tarball here:

http://git.deluge-torrent.org/deluge/snapshot/deluge-1b54d5b93be75a10f235898a6d306cfd4c979564.tar.bz2

comment:4 Changed 8 years ago by simonbcn

Ok, but what's the file to replace?

comment:5 Changed 8 years ago by damoxc

  • Resolution set to fixed
  • Status changed from reopened to closed

That's a tarball of the deluge source tree, so:

wget http://git.deluge-torrent.org/deluge/snapshot/deluge-1b54d5b93be75a10f235898a6d306cfd4c979564.tar.bz2
tar jxf deluge-1b54d5b93be75a10f235898a6d306cfd4c979564.tar.bz2
cd deluge-1b54d5b93be75a10f235898a6d306cfd4c979564
python setup.py build
sudo python setup.py install

you just download, extract, python setup.py

comment:6 Changed 10 months ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.