Opened 8 years ago

Closed 8 years ago

Last modified 10 months ago

#1202 closed bug (Fixed)

AttributeError: Torrent instance has no attribute 'state'

Reported by: simonbcn Owned by:
Priority: major Milestone: 2.x
Component: Core Version: 1.2.3
Keywords: Cc:

Description

deluge 1.2.3 + libtorrent 0.15
Compiled from sources

It shows, in log, this error several times:

[ERROR   ] 02:52:14 rpcserver:286 Exception calling RPC request: Torrent instance has no attribute 'state'
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/core/rpcserver.py", line 281, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/core/core.py", line 430, in get_torrents_status
    status_dict[torrent_id] = self.get_torrent_status(torrent_id, keys)
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/core/core.py", line 412, in get_torrent_status
    status = self.torrentmanager[torrent_id].get_status(keys)
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.2.1-py2.6.egg/deluge/core/torrent.py", line 574, in get_status
    "state": self.state,
AttributeError: Torrent instance has no attribute 'state'

Change History (6)

comment:1 Changed 8 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

This could be a problem if lt 0.15 introduced a new state. I put a fix for this in master so that it will set self.state even in this case.

comment:2 Changed 8 years ago by simonbcn

If I download the last version from git (git clone git://deluge-torrent.org/deluge.git), Will this fix be in that version?

comment:3 Changed 8 years ago by andar

Yes, in the master branch.

comment:4 Changed 8 years ago by simonbcn

The problem is that 1.30 is unstable: http://dev.deluge-torrent.info/ticket/1204
I come back to v1.2.3.
Please, can you say to me the file/s that you have fixed for I'll change it in 1.2.3 version?

comment:5 Changed 8 years ago by anachron

simonbcn: You can see the change andar did here: http://git.deluge-torrent.org/deluge/commit/?id=ee9c7d19711069054509bf66ffb4fb491e365b0c

I have successfully applied it to v1.2.3

comment:6 Changed 10 months ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.