Opened 11 years ago

Closed 11 years ago

#1229 closed defect (Invalid)

Deluge requires libtorrent >=0.14.9.0 when 0.14.10 installed

Reported by: Alex_Justes Owned by:
Priority: major Milestone: 1.2.0
Component: Unknown Version: 1.2.2
Keywords: libtorrent deluged daemon 0.14.9 0.14.10 Cc:

Description

$ deluged -d --loglevel=debug
[INFO    ] 08:54:09 daemon:129 Deluge daemon 1.2.2
[DEBUG   ] 08:54:09 daemon:130 options: {'profile': False, 'loglevel': 'debug', 'quiet': False, 'ui_interface': None, 'interface': None, 'logfile': None, 'config': None, 'port': None, 'pidfile': None, 'donot': True}
[DEBUG   ] 08:54:09 daemon:131 args: []
[ERROR   ] 08:54:09 main:216 This version of Deluge requires libtorrent >=0.14.9.0!
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/deluge/main.py", line 209, in start_daemon
    Daemon(options, args)
  File "/usr/lib64/python2.6/site-packages/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib64/python2.6/site-packages/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib64/python2.6/site-packages/deluge/_libtorrent.py", line 60, in <module>
    check_version(lt)
  File "/usr/lib64/python2.6/site-packages/deluge/_libtorrent.py", line 53, in check_version
    raise ImportError("This version of Deluge requires libtorrent >=%s!" % REQUIRED_VERSION)
ImportError: This version of Deluge requires libtorrent >=0.14.9.0!

The Version of libtorrent installed on my machine is 0.14.10, but deluged requires greater than 0.14.9. Not good.

Change History (1)

comment:1 Changed 11 years ago by andar

  • Milestone changed from 1.4.0 to 1.2.0
  • Resolution set to invalid
  • Status changed from new to closed

This has been fixed in 1.2.3. Please upgrade before submitting bug reports.

Note: See TracTickets for help on using tickets.