Opened 11 years ago

Closed 10 years ago

#1232 closed bug (Fixed)

confusing display of IPv6 addresses in peers tab

Reported by: tikal808 Owned by: Cas
Priority: minor Milestone: 1.3.3
Component: GTK UI Version: 1.2.3
Keywords: ipv6, address, peers tab Cc: naesten@…

Description

When in the peers tab using 1.2.3 on Ubuntu 10.04 IPv6 addresses are sometimes displayed in an incorrect format. Most specifically there is sometimes an extra digit applied to the last quad in the address. (see attached screenshot) Whether or not this is by design I do not know. Regardless, it's currently impossible to perform a a whois lookup on an IPv6 addresses displayed on the peers tab when there is extra digits in the address.

Attachments (1)

deluge-ipv6-sm.png (17.0 KB) - added by tikal808 11 years ago.
screenshot displaying some incorect IPv6 addresses in peers tab

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by tikal808

screenshot displaying some incorect IPv6 addresses in peers tab

comment:1 in reply to: ↑ description Changed 11 years ago by tikal808

  • Priority changed from major to minor

Replying to tikal808:

When in the peers tab using 1.2.3 on Ubuntu 10.04 IPv6 addresses are sometimes displayed in an incorrect format. Most specifically there is sometimes an extra digit applied to the last quad in the address. (see attached screenshot) Whether or not this is by design I do not know. Regardless, it's currently impossible to perform a a whois lookup on an IPv6 addresses displayed on the peers tab when there is extra digits in the address.

These are evidently Teredo (IPv6 in IPv4) endpoints.

comment:2 Changed 11 years ago by tikal808

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 10 years ago by SamB

  • Cc naesten@… added
  • Resolution invalid deleted
  • Status changed from closed to reopened

Um, it doesn't matter *what* kind of IPv6 address those are supposed to be, you can't fit five nybbles in 16 bits...

But I think perhaps the problem is that those last five digits are actually a port number, which would be a lot clearer if the IPv6 addresses were in brackets -- especially considering that many IPv6 addresses have the :: in them, which makes it impossible to tell this just by counting 16 chunks.

comment:4 Changed 10 years ago by SamB

  • Summary changed from incorrect IPv6 address shown in peers tab to confusing display of IPv6 addresses in peers tab

comment:5 Changed 10 years ago by Cas

  • Milestone changed from 1.4.0 to 1.3.3
  • Owner set to Cas
  • Status changed from reopened to assigned

comment:6 Changed 10 years ago by Cas

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in 1.3-stable: ba1cc6e

Note: See TracTickets for help on using tickets.