Opened 8 years ago

Closed 6 years ago

#1301 closed bug (Fixed)

Order of torrents is reversed upon start-up

Reported by: amrhassan Owned by:
Priority: minor Milestone: Future
Component: Core Version: 1.3.5
Keywords: queue Cc:

Description

Every time I restart deluged, I find the order of my torrents reversed in the list.

Change History (6)

comment:1 Changed 8 years ago by amrhassan

  • Component changed from other to core
  • Keywords queue added
  • Summary changed from Order of torrents is reversed upon shutdown to Order of torrents is reversed upon start-up

I just discovered that this is due to me enabling "Queue new torrents on top" from the preferences. This definitely should not be happening.

comment:2 Changed 8 years ago by noelbush

This happens to me whether or not I have the "Queue new torrents on top" option enabled. For the time being, whenever I have to restart Deluge for some reason, I just start it once, then quit, then start it again. Silly but it works.

comment:3 Changed 7 years ago by Cas

  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce with 1.3.2

comment:4 Changed 6 years ago by ViTality

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 1.2.3 to 1.3.5

It reproduce with 1.3.5 for me every restart.

comment:5 Changed 6 years ago by Cas

Actually after enabling "Queue new torrents on top", I do actually see this issue.

comment:6 Changed 6 years ago by gazpachoking

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in 666bb09513

Note: See TracTickets for help on using tickets.