Opened 14 years ago

Closed 14 years ago

#1312 closed defect (Fixed)

deluge web ui uses 100% CPU after some time.

Reported by: non7top Owned by: damoxc
Priority: critical Milestone: 1.3.1
Component: Web UI Version: 1.3.0
Keywords: Cc:


I'm running deluge web ui on a separate server and CPU usage is constantly increasing reaching 100% after about 3 days. web ui page in broser also becomes very slow. Right after starting web ui cpu usage is normal.

Attachments (1)

deluge_web.png (19.2 KB) - added by vorgusa 14 years ago.
cacti graph

Download all attachments as: .zip

Change History (7)

comment:1 Changed 14 years ago by voyager

I am experiencing this too.

Package: On Ubuntu Lucid Lynx.

Reaching 100% load sometimes is done within hours!

I've tried not changing any settings in webui while torrents are active and not logging into webui but that doesn't seem to help.

Restarting deluge (using the ubuntu init-script) makes load go down to <10% even if torrents are still running.

I am now considering going back to Transmissionbt, even if their current webui can by no means compete with yours.

If further information is needed just ask :)

comment:2 Changed 14 years ago by vorgusa

  • Component changed from other to webui
  • Owner set to damoxc

I am experiencing the same thing.. slowly goes up after time. I have the version of 1.3 from the deluge repository on Ubuntu 10.04 server

Changed 14 years ago by vorgusa

cacti graph

comment:3 Changed 14 years ago by voyager

Guess i need to take back what i said about not logging in. It DOES help. I downloaded 4 torrents during the past few days and deluge-web is still not causing any noticable load.

I did not even open the web-ui url since the last restart.

BUT not using the web-ui to solve this problem sort of defies the purpose.

I'm now gonna open the web-ui log in screen without actually doing anything. Just open it, close it again and see if any load will be coming up till tomorrow/the next days.

comment:4 Changed 14 years ago by damoxc

  • Milestone changed from Future to 1.3.1
  • Priority changed from major to critical
  • Status changed from new to accepted
  • Version changed from 1.3.0_dev to 1.3.0

comment:5 Changed 14 years ago by damoxc

I believe this has been fixed by a recent commit if you would mind testing it?

comment:6 Changed 14 years ago by damoxc

  • Resolution set to fixed
  • Status changed from accepted to closed

I have now been running deluge-web with the fix for 2 days now and it is still at low (0% cpu) when no one is connected, so I'm marking this as fixed.

Note: See TracTickets for help on using tickets.