Opened 14 years ago

Closed 13 years ago

#1353 closed bug (Invalid)

deluge-gtk crashes with Segmentation Fault on startup

Reported by: Drooling_Sheep Owned by:
Priority: major Milestone: Future
Component: GTK UI Version: 1.3.0_dev
Keywords: crash Cc:


I've been using deluge 1.3.0-rc2 for a few days now and it has had occasional crashes but been mostly usable. I unchecked classic mode so I could connect to the daemon from another computer, but now when I start deluge-gtk, the window for choosing a daemon pops up for a split second then there's a segmentation fault.

Change History (3)

comment:1 by John Garland, 14 years ago

If you're getting a segfault than that's libtorrent dying. Would you be able to run it in gdb and paste the output here?

comment:2 by Drooling_Sheep, 14 years ago

I installed the libc6-dbg python-dbg and libtorrent-rasterbar-dbg ubuntu packages (maverick)

I ran 'gdb --args python /usr/bin/deluge-gtk'

here is the output

abransco@mediaserver:~$ gdb --args python /usr/bin/deluge-gtk GNU gdb (GDB) 7.1-ubuntu Copyright (C) 2010 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Type "show copying" and "show warranty" for details. This GDB was configured as "i686-linux-gnu". For bug reporting instructions, please see: <>... Reading symbols from /usr/bin/python...Reading symbols from /usr/lib/debug/usr/bin/python2.6...done. done. (gdb) run Starting program: /usr/bin/python /usr/bin/deluge-gtk [Thread debugging using libthread_db enabled] Xlib: extension "RANDR" missing on display ":1.0". [New Thread 0xb5193b70 (LWP 5473)] [New Thread 0xb47ffb70 (LWP 5474)] [New Thread 0xb3ffeb70 (LWP 5475)] [New Thread 0xb34ffb70 (LWP 5476)]

Program received signal SIGSEGV, Segmentation fault. _int_malloc (av=<value optimized out>, bytes=<value optimized out>)

at malloc.c:4439

4439 malloc.c: No such file or directory.

in malloc.c

(gdb) quit A debugging session is active.

Inferior 1 [process 5468] will be killed.

Quit anyway? (y or n) y

I figured out the problem. I usually access this computer via the display :1 which is created by vncserver. something about this setup causes a segfault in malloc, possibly that the extension RANDR isn't on for this display. I do this so I can access a desktop at the same time as I'm running xbmc on :0. I tried running deluge on :0 after exiting xbmc and it works fine.

comment:3 by Calum, 13 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.