Opened 11 years ago

Closed 11 years ago

Last modified 5 years ago

#1362 closed bug (Fixed)

Major Memory Leak

Reported by: Oehr Owned by:
Priority: critical Milestone:
Component: libtorrent Version: 1.3.0
Keywords: Cc: sh@…

Description

After running Deluge 1.2.3 for a while, all of my RAM was in use...

When i shut down Deluge, it jumped back to only 2GB of 16GB in use: http://img267.imageshack.us/img267/7559/ss20100918150913.png

I also tested Deluge 1.3 RC2. It seems to have the same memory leak, because after only after 3hours, ram usage increased by roughly 1-2GB and is steadily growing... Both Task Manager or Process Explorer don't show which program is using all those GB, but once you shut down deluge, you get most of your ram back.

Disk I/O is always around 7MB/s, so it's easily manageable for the harddrive.

The server is running Windows Server Edition 2008 R2 with latest updates installed.

Change History (15)

comment:1 Changed 11 years ago by andar

  • Component changed from core to libtorrent

comment:2 Changed 11 years ago by johnnyg

  • Milestone changed from 1.3.0 to 1.3

comment:3 Changed 11 years ago by deviantintegral

  • Version changed from 1.2.3 to 1.3.0

I'm also running into this issue. I'm using the Ubuntu 10.10 source packages built on Ubuntu 10.04. I think it might be related to when a tracker times out - I'm testing now to see if I can replicate it.

comment:4 Changed 11 years ago by andar

What version of libtorrent? There is a known problem with 0.15.3 and error'd trackers.

comment:5 Changed 11 years ago by deviantintegral

I'm using:

ii  libtorrent-rasterbar6                      0.15.3-0ubuntu1                                         C++ bittorrent library by Rasterbar Software

So that issue is likely the problem. I guess installing libtorrent from SVN trunk (and not using the Ubuntu 10.10 source packages) is the best solution?

comment:6 Changed 11 years ago by andar

Please try using the RC_0_15 branch of libtorrent and see if that solves your problem.

comment:7 Changed 11 years ago by deviantintegral

I installed it by creating a patch and applying it to the sources used to build the Ubuntu package. deluged has been running for an hour now without issue, so it looks like the issue is fixed.

Leaving open for now in case the original reporter still has the problem on Windows.

comment:8 Changed 11 years ago by whoozle

gentoo x86_64, deluge 1.2.3/1.3.0, sometime deluged goes mad using 100% cpu and moving something on the disks endlessly. This ends with all programs swapped and all memory'd been eaten up. :(

libtorrent-0.12.6

comment:9 Changed 11 years ago by graysky

Glad to hear this is the fault of libtorrent-rasterbar. I can confirm the bug under Arch Linux also running libtorrent-rasterbar-0.15.3 with deluge-1.3.0.

http://forum.deluge-torrent.org/viewtopic.php?f=7&t=33395

Downgrading to libtorrent-rasterbar-0.15.2 seems to have fixed the problem.

comment:10 Changed 11 years ago by Svenstaro

  • Cc sh@… added

What's the status on this?

comment:11 Changed 11 years ago by socker

From libtorrent-rasterbar-0.15.4 changelog:

  • fixed announce issue which could cause high CPU and memory usage

comment:12 Changed 11 years ago by Svenstaro

I suggest this should be closed then.

comment:13 Changed 11 years ago by damoxc

  • Resolution set to fixed
  • Status changed from new to closed

Closing this due to new libtorrent release.

comment:14 Changed 11 years ago by Thump

Will libtorrent-rasterbar-0.15.4 be included in 1.3.2?

comment:15 Changed 5 years ago by Cas

  • Milestone 1.3.x deleted

Milestone deleted

Note: See TracTickets for help on using tickets.