Opened 11 years ago

Closed 10 years ago

#1386 closed bug (Fixed)

[win32] 'Add Torrent' using non-ascii Download Location

Reported by: Thump Owned by: Cas
Priority: minor Milestone: 1.3.2
Component: GTK UI Version: 1.3.1
Keywords: utf8 Cc:

Description

I can't point Deluge 1.3.1 on Windows XP SP3 x86-32 to save downloading content to destination path containing non-ascii symbols.

For debug log it was used 'C:\Temp\Тест\Test' destination folder, but Deluge making a new directory and saving the files there: 'C:\Temp\Тест\Test'

On Windows 7 SP1 x86-32 it doesn't downloading at all, maybe because of the non-administrative rights to make new folders.

Take a look at debug log when 'C:
Temp
\u0422\u0435\u0441\u0442
Test' becomes 'C:
Temp
\xd0\xa2\xd0\xb5\xd1\x81\xd1\x82
Test'

Attachments (1)

cyr-path-deluge-debug.log (46.4 KB) - added by Thump 11 years ago.
Debug-level log of deluge.exe 1.3.1

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by Thump

Debug-level log of deluge.exe 1.3.1

comment:1 Changed 11 years ago by Thump

  • Milestone changed from 1.3.x to 1.3.2
  • Version changed from other (please specify) to 1.3.1

comment:2 Changed 11 years ago by damoxc

  • Summary changed from MS Windows destination path to download non-ascii to [win32] destination path to download non-ascii

comment:3 Changed 10 years ago by Cas

  • Resolution set to duplicate
  • Status changed from new to closed

I cannot replicate this on Ubuntu or Windows XP, using the suggested characters.

I think this is likely to be a permissions issue but I will set it as duplicate of #1373.

The log file shows that the path was converted from unicode to hex so is not the issue.

comment:4 Changed 10 years ago by Thump

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Cas, I've installed Windows XP SP3 in VurtualBox, then I've applied all high-priority updates, installed latest Deluge 1.3.1 (deluge-1.3.1-win32-setup.exe), installed "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)", tried to download torrent and now I've got a video-proof. http://oshirochenkov.info/upload/deluge-non-ascii-target.avi

comment:5 Changed 10 years ago by Cas

  • Resolution set to duplicate
  • Status changed from reopened to closed

Thanks for video it confirms what I see.

After closing this ticket I actually rechecked on win XP and did find the issue but updated #1373 as this ticket is a duplicate.

comment:6 Changed 10 years ago by Cas

  • Component changed from core to gtkui
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from [win32] destination path to download non-ascii to [win32] 'Add Torrent' using non-ascii Download Location

Looking further into this it seems that although the same windows non-ascii path issue occurs as #1373, it is a different part of Deluge code.

comment:7 Changed 10 years ago by Cas

  • Owner set to Cas
  • Status changed from reopened to accepted

comment:8 Changed 10 years ago by Cas

  • Resolution set to fixed
  • Status changed from accepted to closed

1.3-stable: 93091fbe23

Note: See TracTickets for help on using tickets.