Opened 11 years ago

Closed 10 years ago

#1398 closed bug (WorksForMe)

deluge-console commands with parameter --help fail

Reported by: xpozitron Owned by:
Priority: trivial Milestone: Future
Component: Console UI Version: 1.3.1
Keywords: Cc:

Description

When I am running commands from command line with parameter --help it fails.

$ deluge-console info --help Traceback (most recent call last):

File "/usr/bin/deluge-console", line 8, in <module>

load_entry_point('deluge==1.3.1', 'console_scripts', 'deluge-console')()

File "/usr/lib/pymodules/python2.6/deluge/ui/console/main.py", line 74, in start

Console().start()

File "/usr/lib/pymodules/python2.6/deluge/ui/console/main.py", line 69, in start

super(Console, self).start()

File "/usr/lib/pymodules/python2.6/deluge/ui/ui.py", line 87, in start

(self.options, self.args) = self.parser.parse_args()

File "/usr/lib/python2.6/optparse.py", line 1394, in parse_args

stop = self._process_args(largs, rargs, values)

File "/usr/lib/python2.6/optparse.py", line 1434, in _process_args

self._process_long_opt(rargs, values)

File "/usr/lib/python2.6/optparse.py", line 1509, in _process_long_opt

option.process(opt, value, values, self)

File "/usr/lib/python2.6/optparse.py", line 788, in process

self.action, self.dest, opt, value, values, parser)

File "/usr/lib/python2.6/optparse.py", line 810, in take_action

parser.print_help()

File "/usr/lib/python2.6/optparse.py", line 1664, in print_help

file.write(self.format_help().encode(encoding, "replace"))

UnicodeDecodeError?: 'ascii' codec can't decode byte 0xc5 in position 35: ordinal not in range(128)

$ deluge-console "info --help" Error parsing options: 'ascii' codec can't decode byte 0xc5 in position 135: ordinal not in range(128)

$ deluge-console "add --help" Error parsing options: 'ascii' codec can't decode byte 0xc5 in position 71: ordinal not in range(128)

Version: deluge 1.3.1-2~karmic~ppa1 deluge-common 1.3.1-2~karmic~ppa1 deluge-console 1.3.1-2~karmic~ppa1 deluge-gtk 1.3.1-2~karmic~ppa1 deluge-web 1.3.1-2~karmic~ppa1 deluged 1.3.1-2~karmic~ppa1

Linux Arcueid 2.6.31-22-generic #68-Ubuntu SMP Tue Oct 26 16:38:35 UTC 2010 i686 GNU/Linux

Change History (2)

comment:1 Changed 10 years ago by Cas

  • Priority changed from major to trivial
  • Status changed from new to pending
  • Type changed from defect to bug

I cannot reproduce this.

There may be an issue with your system setup to cause this. You could try asking on the ubuntu forums.

comment:2 Changed 10 years ago by Cas

  • Resolution set to worksforme
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.