Opened 16 years ago

Closed 16 years ago

#144 closed bug (WorksForMe)

Crash WebUI after login

Reported by: micehide Owned by: mvoncken
Priority: major Milestone:
Component: Web UI Version:
Keywords: webui crash Cc: micehide@…

Description

Crash WebUI after login... Any ideas?

--Deluge Error--
TypeError : update() argument 1 must be string or read-only buffer, not None
path : /login
file : /usr/share/deluge/plugins/WebUi/webserver_framework.py in check_pwd, line 188

--Input--
<Storage {'pwd': '', 'redir': '', 'submit': 'Submit'}>

--Versions--
WebUi : rev.172
Python : 2.5.1 (r251:54863, Oct  5 2007, 13:36:32) 
[GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)]
dbus:0.82.0

--Traceback--
  File "/usr/share/deluge/plugins/WebUi/lib/webpy022/webapi.py", line 304, in wsgifunc
    result = func()
  File "/usr/share/deluge/plugins/WebUi/lib/webpy022/request.py", line 131, in <lambda>
    func = lambda: handle(inp, fvars)
  File "/usr/share/deluge/plugins/WebUi/lib/webpy022/request.py", line 61, in handle
    return tocall(*([x and urllib.unquote(x) for x in args] + fna))
  File "/usr/share/deluge/plugins/WebUi/deluge_webserver.py", line 87, in POST
    if check_pwd(vars.pwd):
  File "/usr/share/deluge/plugins/WebUi/webserver_framework.py", line 189, in check_pwd
    m.update(ws.config.get('pwd_salt'))

Change History (2)

comment:1 Changed 16 years ago by mvoncken

5.x ? set a password inn the gtk-ui.

comment:2 Changed 16 years ago by mvoncken

  • Resolution set to worksforme
  • Status changed from new to closed

caused by a broken config. update your password in gtk-ui

Note: See TracTickets for help on using tickets.