Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#146 closed bug (Fixed)

Peers tab shows duplicate peers when showing country flag

Reported by: danii Owned by: andar
Priority: minor Milestone:
Component: GTK UI Version: 0.6.0svn
Keywords: peers tab country flag Cc:

Description

Deluge 0.6.0.0r3112

when I select the peers tab, duplicate peers are shown when the country flag is displayed, I keep getting this error

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/deluge/ui/gtkui/peers_tab.py", line 274, in _on_get_torrent_status
    row = self.liststore.append([
TypeError: value is of wrong type for this column

gtkui and daemon keep working

Attachments (2)

deluge-peers.jpg (60.0 KB) - added by danii 13 years ago.
duplicate peers
b166.torrent (13.5 KB) - added by danii 13 years ago.
torrent with problematic peers

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by andar

I am unable to reproduce this.. Are you sure that you are connecting to an updated daemon?

comment:2 Changed 13 years ago by danii

well I allways kill deluge tasks before restarting the daemon, I'm using ccache gonna rebuild deluge without it and see if it helps i only happens with some peers i'm uploading a screenshot

Changed 13 years ago by danii

duplicate peers

comment:3 Changed 13 years ago by danii

well I've rebuild Deluge, and removed ~/.config/deluge and the problem persists

comment:4 Changed 13 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [3119]

comment:5 Changed 13 years ago by danii

  • Resolution fixed deleted
  • Status changed from closed to reopened

problem persists in rev 3119, did the hole 9 yards, remove deluge installation, compile without ccache, brand new ~/.config/deluge, same error as before

comment:6 Changed 13 years ago by andar

I am unable to reproduce this. I did manage to reproduce it the first time and thus the 3119 commit. I have been running this since and have not seen any duplicate peers. Is there any console output? Are you sure you updated both client and daemon?

Changed 13 years ago by danii

torrent with problematic peers

comment:7 Changed 13 years ago by danii

I removed all previous versions to make sure client and daemon are the same version,I've noticed only some peers trigger this behavior I'm uploading a torrent that has some of these peers, if you still can't reproduce it, tell me what you need to track down the problem

comment:8 Changed 13 years ago by danii

I forgot, the moment I select Peers tab the console output is

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/deluge/ui/gtkui/peers_tab.py", line 274, in _on_get_torrent_status
    row = self.liststore.append([
TypeError: value is of wrong type for this column

same as before as I said, sometimes the duplicate peer flag is shown sometimes it isn't, also peers that get duplicate rarely share country, client and can be seeding or leeching also I tried disabling the blocklist plugin nothing changed

comment:9 Changed 13 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed

Ok, I believe this is fixed now in [3136]

comment:10 Changed 13 years ago by anonymous

  • Milestone 0.6.0 deleted

Milestone 0.6.0 deleted

Note: See TracTickets for help on using tickets.