Opened 10 years ago

Closed 8 years ago

Last modified 5 years ago

#1531 closed bug (Fixed)

gtk ui not working after upgrade

Reported by: matthieu Owned by:
Priority: major Milestone:
Component: GTK UI Version: 1.3.5
Keywords: Cc: uus1@…, g2sainfroc@…

Description

I recently upgraded from 1.2.3 to 1.3.1 (debian testing) and I cannot connect from GTK UI (1.3.1) on windows to deluged on linux. In the connection manager, I can see the server online. When I connect the status bar is updated once but no torrent list (left and right sides). I can see packets transfered on the network. I didn't found information on the debug output.

deluge-console is working localy and deluged transfert files. Please note that I use deluge with a large number of torrents (more than 300), so I used another server to reproduce the problem.

I was able to reproduce the problem when downloading more than 20 torrents on http://mononoke-bt.org. It seems to be related to the max download but I didn't reproduce it with http://www.nyaa.eu. Please also note that mononoke-bt is authenticated and simultaneous download are limited.

The exact same list of torrents where working fine in 1.2.3.

Attachments (5)

gtk.log (26.6 KB) - added by matthieu 10 years ago.
deluge-gtk debug
deluged.log (166.6 KB) - added by matthieu 10 years ago.
deluged debug log
deluged.log_lin (439 bytes) - added by uus 9 years ago.
deluged.log_win (5.4 KB) - added by uus 9 years ago.
deluged.log.tar.lzma (19.8 KB) - added by uus 9 years ago.
fail after adding 170 files from the folder

Download all attachments as: .zip

Change History (20)

comment:1 Changed 10 years ago by Cas

  • Type changed from defect to bug

There is very little information on how to reproduce this issue. When you say downloading 20 torrents do you mean simultaneously? what bandwidth are they using? Is there high diskio or cpu usage?

Could you supply debug logs of both client and daemon.

comment:2 Changed 10 years ago by matthieu

Thanks for the quick reply. Yes when downloading simultaneously all the torrents on the first page. It doesn't seems to be related to cpu/ram or bandwidth (the 2 computers are very different but the issue is the same) I will upload a clean debug log today, there was no trace on my server.

Changed 10 years ago by matthieu

deluge-gtk debug

Changed 10 years ago by matthieu

deluged debug log

comment:3 Changed 10 years ago by matthieu

So here is the debug logs, the client try to connect at [INFO ] 16:14:55 client:221 Connecting to daemon at 192.168.10.3:58846.. Time is synchronized on both client and server.

I forgot to add that the problem only happen when connecting back to the server : I first add the torrents and everything is alright, then I close the client and when I connect back the screen is white.

comment:4 Changed 10 years ago by IA

I also have this problem

Server is 1.3.1 on gentoo ~x86, client - 1.3.1, W7 x86

deluged current seeding 228 torrents, from many trackers, usualy active 20-30 with upload speed 10-30 mbit. On first connect torrents list and list of states/trackers/labels a empty, but plugins loaded (labels, stats, pieces) Icon in system tray updated once (show download and upload speeds and limits)

If in this state press Connection manager button - icon of server looks like connected, but button is still named "Connect". Pressing it actualy disconnect from server.

If not closing client try to connect second time - list of states (on left side) loaded, but torrents list not.

I try also build deluge from source - problem a still exist. I try connect not from windows machine but from Ubuntu (Mint 10 Julia) with deluge installed from ppa - same empty lists.

But if i restarted deluged daemon on server 5-10 times - gtk ui begin connects...

Sorry for my bad english.

comment:5 Changed 10 years ago by IA

After update from git - new console ui also stop working - it hang on "Waiting for torrents from core..." Also no reaction to commands like "deluge-console halt", trick with restarting deluged few times not work, so now i have no control over daemon at all...

comment:6 Changed 9 years ago by Florby

I am having the same problem with 1.3.3.

GTK-GUI: Connects to daemon, but doesnt list torrents or anything else. Will not let me open preferences, etc

Webui: Sees daemon, tries to connect but fails

Console: Displays the "bar" with up/down speed, limits, number of connections, but no torrents.

I've had this problem for about 2 weeks now, and at random times I've been able to open the gtk-gui by retrying many times, but I cant seem to get it back now after about 10 tries.

My deluged.log is empty and console output from deluge-gtk spouts some standard gtk stuff ((deluge:15270): Gtk-WARNING : Unable to locate theme engine in module_path: "pixmap")

Note: I have many many torrents (around 1000) seeding.

comment:7 follow-up: Changed 9 years ago by Cas

As I said before with no information to go on and being unable to reproduce ourselves it is impossible for us to debug this.

You will need try testing different scenarios with the config. For example setting up a clean config, check clients connect then copy the state folder over that contains all your torrent info and try again.

Are you connecting locally or over network to deluged?

Changed 9 years ago by uus

Changed 9 years ago by uus

comment:8 in reply to: ↑ 7 Changed 9 years ago by uus

  • Cc uus1@… added
  • Version changed from 1.3.1 to 1.3.5

Replying to Cas:

As I said before with no information to go on and being unable to reproduce ourselves it is impossible for us to debug this.

You will need try testing different scenarios with the config. For example setting up a clean config, check clients connect then copy the state folder over that contains all your torrent info and try again.

Are you connecting locally or over network to deluged?

Hi! I have the same issue. I try to connect over the network to deluged. Systems are: Linux ustor 3.0.0-17-server #30-Ubuntu SMP Thu Mar 8 22:15:30 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux (deluged)(172.16.0.10) Linux uusx 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 20:45:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux deluge-gtk(172.16.0.2) windows 7 corporate x32 (172.16.0.6) deluge version:1.3.5 server is a new installation of deluged. Yesterday it worked fine, but afer adding several(~50) torrents from http://tracker.hdclub.com.ua and rebooting i have what i have.

deluge_win is when windows laptop tried to connect; deluge_lin is from the moment linux PC tried to connect. as i can assume the main point of the logs is [INFO ] 17:48:35 rpcserver:203 Deluge Client connection made from: 172.16.0.2:48259 [INFO ] 17:48:35 rpcserver:223 Deluge client disconnected: Connection was closed cleanly.

creating new profile for deluge helps to resolve the issue but you loose all the torrents states((( I also do next(on server): stop deluged;
mv .config/deluge/state .config/deluge/state_old;
start deluged; <- at this point remote client was already able to connect to deluged
stop deluged;
rm -rvf .config/deluge/state
mv .config/deluge/state_old/ .config/deluge/state

so it helped:remote clients are able to connect to deluged without loosing torrents state.

comment:9 Changed 9 years ago by uus

the workaround didn't helped for a long time - same issue in 3-5 minutes. while deluged was working- added a directory to pick up torrent files automatically, restarted deluged,copyed all the 170 files to that directory and deluged failed again. The log file size is 560k - how can i send it to you?

Changed 9 years ago by uus

fail after adding 170 files from the folder

comment:10 Changed 9 years ago by effede

  • Cc g2sainfroc@… added

comment:11 Changed 9 years ago by matthieu

Hi Cas

Do the information I sent after your first reply are useful ? I didn't get your feedback on that. I confirm this problem is still present, but I reduced the number of seed to make deluge work.

Best regards, Matthieu

comment:12 Changed 9 years ago by bro

Hi

I encountered the same issue described here and I think I've found a solution: http://dev.deluge-torrent.org/ticket/2116

comment:13 Changed 9 years ago by Cas

  • Status changed from new to pending

I recently fixed a very similar issue in the forum and I believe it is a component of the several issues covered in #2116. This fix will be committed to git but it would be useful if someone can report whether this helps them also.

@@ -164,7 +164,7 @@
         t = s.decode("utf8")
         if len(t) != len(s):
             s = t
-    except UnicodeEncodeError:
+    except UnicodeDecodeError:
         pass
     return (s, colon+n)
 
@@ -223,7 +223,7 @@
                 t = s.decode("utf8")
                 if len(t) != len(s):
                     s = t
-            except UnicodeEncodeError:
+            except UnicodeDecodeError:
                 pass
             return (s, f+1+slen)
         return f

comment:14 Changed 8 years ago by Cas

  • Resolution set to fixed
  • Status changed from pending to closed

comment:15 Changed 5 years ago by Cas

  • Milestone 1.3.x deleted

Milestone deleted

Note: See TracTickets for help on using tickets.