Opened 11 years ago

Closed 10 years ago

#1535 closed bug (Fixed)

Unnecessary horizontal scrollbar appears when only vertical should

Reported by: SIO Owned by:
Priority: minor Milestone: 1.3.2
Component: GTK UI Version: 1.3.1
Keywords: Cc:

Description

Description

Because of the width of the last column in any table is not fixed but varies from minimum (set by user) to maximum (set by the width of the window) following happens:

When a row is being added to table (torrent list, file list, peer list) so that this table has to be scrolled up-down, the width of the last column in the table stays the same, though the width of the widget decreases by the width of the scrollbar. And horizontal scrollbar appears

But if the last column was wider than it is needed to show all its content that horizontal scrollbar is unnecessary.

Steps to reproduce

  1. Tune the torrent list so that it wouldn't have any scrollbars
  2. Increase window width by 40-50px (see attached "Screenshot 1.png")
  3. Increase the height of the torrent properties section so that torrent list had to get vertical scrollbar (see attached "Screenshot 2.png")

Expected behavior

Only vertical scrollbar appears

Actual behavior

Both horizontal and vertical scrollbars appear. And to illustrate it is just because of the added width of vertical scrollbar you can decrease the height of torrents properties section, and both scrollbars will disappear

This bug applies not only to torrent list as in the example above, but also to file list and peer list in torrent properties tabs.

System information

Deluge Core version: 1.3.1
libtorrent version: 0.14.10.0
Debian Sid, 2.6.37 kernel

Attachments (2)

Screenshot_1.png (103.2 KB) - added by SIO 11 years ago.
Screenshot 1. At the end of step 2 from "Steps to reproduce"
Screenshot_2.png (100.9 KB) - added by SIO 11 years ago.
Screenshot 2. At the end of step 3 from "Steps to reproduce"

Download all attachments as: .zip

Change History (8)

comment:2 Changed 11 years ago by Cas

  • Milestone changed from Future to 1.3.x
  • Type changed from defect to bug

Part of this issue was fixed in #1336.

Do you mind uploading the images again.

Changed 11 years ago by SIO

Screenshot 1. At the end of step 2 from "Steps to reproduce"

Changed 11 years ago by SIO

Screenshot 2. At the end of step 3 from "Steps to reproduce"

comment:3 Changed 11 years ago by SIO

Ok, now I get it: spaces in filenames = not good :) Please delete previously attached files

comment:4 follow-up: Changed 10 years ago by Cas

  • Status changed from new to pending

I think this is fixed in 1.3.2 can you retest please.

comment:5 in reply to: ↑ 4 Changed 10 years ago by SIO

  • Status changed from pending to new

Sorry, I don't use deluge anymore. Anyway, 1.3.2 is not in Debian repos yet, and it won't be there for a while

comment:6 Changed 10 years ago by SIO

  • Status changed from new to pending

Accidentally changed status

comment:7 Changed 10 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.2
  • Resolution set to fixed
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.