Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#1538 closed bug (WorksForMe)

AppIndicator breaks trayicon

Reported by: s0undt3ch Owned by: Cas
Priority: major Milestone:
Component: GTK UI Version: 1.3.0_dev
Keywords: Cc:

Description

Ever since #1514 got integrated into master I no longer have a working system tray. No Icons and the action do not work. After -TERMinating deluge, the trayicons just keep piling up

Change History (16)

comment:1 Changed 13 years ago by s0undt3ch

  • Summary changed from AppIndicator breaks to AppIndicator breaks trayicon

comment:2 Changed 13 years ago by s0undt3ch

  • Owner set to Cas
  • Status changed from new to assigned

comment:3 Changed 13 years ago by Cas

  • Component changed from other to gtkui
  • Type changed from defect to bug

please provide a debug log and what os you are using

comment:4 Changed 13 years ago by s0undt3ch

Kubuntu in between a lucid, maverick change, ie, mostly lucid, some packages maverick, haven't fully upgraded.

Nothing shows up on the debug logs, I've checked.

comment:5 Changed 13 years ago by Cas

  • Milestone changed from 1.3.2 to 1.4.0

I hope you realise that the master branch is unstable currently.

Do you have Indicator Applet installed?

It would be helpful could you test with 1.3-stable to see if you experience the same result.

comment:6 Changed 13 years ago by s0undt3ch

Ok, now I realize, Application Applet is a Gnome applet. I had the python-appindicator package installed, so I though I was good.

Why do we KDE users have to depend on that!? It's just a bunch of "sh*tty"(in my humble opinion) gnome app deps.

The solution you've found is not the best. Ideally you should test for a gnome session running or such, and if so, use appindicator, if not, leave the code as it was.

Regarding the stable branch, I think that's the branch the ubuntu ppa packages are built against, so, it's actually good.

comment:7 follow-up: Changed 13 years ago by Grundoko

It checks to see if indicator-applet is running (If it's in your panel, it's running). If so, it uses the Appindicator.

If indicator-applet isn't running, it will use the Notification Area.

comment:8 in reply to: ↑ 7 Changed 13 years ago by s0undt3ch

Replying to Grundoko:

It checks to see if indicator-applet is running (If it's in your panel, it's running). If so, it uses the Appindicator.

If indicator-applet isn't running, it will use the Notification Area.

You mean this check?

The only thing checked is if it was imported, or am I missing something?

comment:9 Changed 13 years ago by Grundoko

Oh, so you're right. It only checks if you have it installed, not if it's running. That should be changed.

comment:10 Changed 13 years ago by Cas

The Ubuntu PPA is built from the official releases deluge-1.3.1 etc..

stable-1.3 is the working branch for the next 1.3.x release.

I did not write the initial patch however by my reckoning if you can import appindicator then it would be assumed you can handle the new app indicators.

comment:11 Changed 13 years ago by Cas

I forgot to add that a debug log is still useful so can you please attach one

comment:12 Changed 13 years ago by Grundoko

I believe the problem is that checking if it can be imported only shows if it's installed or not, not if it can actually be used (IE: is the indicator-applet actually in the panel?)

Maybe he has it installed, but not added as a panel applet, and Deluge is thinking he has it, and tries to use the indicator-applet even though it's not running.

Just my first assumption, I don't know a whole lot about using the indicator-applet, maybe it can only import if it's actually running.

comment:13 follow-up: Changed 13 years ago by Cas

  • Resolution set to worksforme
  • Status changed from assigned to closed

After a little research I found that appindicator is actually based on knotify and will work on both KDE and Gnome just fine. There are a lot of applications using appindicator now and none require extra checking.

I have tested removing the notification and indicator applet in gnome and found no issue.

Without any evidence that this is a Deluge code issue I have to suspect a system problem, if you can reproduce on a clean kubuntu install then this can be reopened.

comment:14 in reply to: ↑ 13 ; follow-up: Changed 13 years ago by s0undt3ch

Replying to Cas:

After a little research I found that appindicator is actually based on knotify and will work on both KDE and Gnome just fine. There are a lot of applications using appindicator now and none require extra checking.

I have tested removing the notification and indicator applet in gnome and found no issue.

Without any evidence that this is a Deluge code issue I have to suspect a system problem, if you can reproduce on a clean kubuntu install then this can be reopened.

Just cleaned up my system, running a fresh maverick now, I was apparently needing it ;)

All good, current master works as supposed, still using trayicon though.

comment:15 in reply to: ↑ 14 Changed 13 years ago by s0undt3ch

Replying to s0undt3ch:

Replying to Cas:

After a little research I found that appindicator is actually based on knotify and will work on both KDE and Gnome just fine. There are a lot of applications using appindicator now and none require extra checking.

I have tested removing the notification and indicator applet in gnome and found no issue.

Without any evidence that this is a Deluge code issue I have to suspect a system problem, if you can reproduce on a clean kubuntu install then this can be reopened.

Just cleaned up my system, running a fresh maverick now, I was apparently needing it ;)

All good, current master works as supposed, still using trayicon though.

I'm on Kubuntu

comment:16 Changed 11 years ago by Cas

  • Milestone 1.4.0 deleted
Note: See TracTickets for help on using tickets.