Opened 13 years ago

Closed 13 years ago

#1542 closed bug (Duplicate)

Deluge webUI don't save some preferences

Reported by: simonbcn Owned by: Damien Churchill
Priority: major Milestone: Future
Component: Web UI Version: 1.3.1
Keywords: Cc:


deluged + deluge-web in server.

I connect remotely and I try to config via webUI, but it don't save: Incoming/Outgoing Ports, Global Bandwidth Usage/Maximum Connections and other options.
Sometimes it saves the options but it return to defaults later, in this cases it shows this output:

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.3.1-py2.6.egg/deluge/", line 214, in start_daemon
    Daemon(options, args)
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.3.1-py2.6.egg/deluge/core/", line 171, in __init__
  File "/usr/lib/python2.6/dist-packages/twisted/internet/", line 1170, in run
  File "/usr/lib/python2.6/dist-packages/twisted/internet/", line 1179, in mainLoop
--- <exception caught here> ---
  File "/usr/lib/python2.6/dist-packages/twisted/internet/", line 778, in runUntilCurrent
    call.func(*call.args, **
  File "/usr/local/lib/python2.6/dist-packages/deluge-1.3.1-py2.6.egg/deluge/core/", line 467, in _on_new_release_check
  File "/usr/lib/python2.6/dist-packages/twisted/internet/", line 171, in stop
    assert self.running, ("Tried to stop a LoopingCall that was "
exceptions.AssertionError: Tried to stop a LoopingCall that was not running.

Change History (1)

comment:1 by Calum, 13 years ago

Resolution: duplicate
Status: newclosed

See #1370

Note: See TracTickets for help on using tickets.