Opened 11 years ago

Closed 10 years ago

#1571 closed bug (Invalid)

Error: Bad address using a https tracker

Reported by: MarbolanGos Owned by:
Priority: minor Milestone:
Component: libtorrent Version: 1.3.1
Keywords: Cc:

Description

Hi,

first thing I really love this torrent interface and I nearly wanted to leave the tracker as they did not work with deluge... The title is perhaps incorrect as I have seen this bug: http://dev.deluge-torrent.org/ticket/631. But I cannot see any other explanation on this bug...

Here is the thing, I use deluge on 2-3 trackers without any issue and then I started to use another tracker with an https address in the announce. When I get any torrent I have the error: "Error: Bad address".

What did I try unsuccessfully?

  • Changing deluge version from 1.3.0 (Fedora 14 basic version) to 1.3.1.
  • Changing port for the UDP/TCP connexion: tried 6885, 16885 and 56566! I am sure it is not a firewall issue as, at the end, I set-up to dmz for my router and shutdown iptables.
  • Tried to redownload the torrent many times.
  • Changed my passkey on the tracker.

What should be known is that other torrents are working while doing those tests. My kernel: Linux node0 2.6.35.11-83.fc14.x86_64 #1 SMP Mon Feb 7 07:06:44 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux. My configuration file:

$ cat ~/.config/deluge/core.conf
{
  "file": 1,
  "format": 1
}{
  "info_sent": 1298396897.396568,
  "lsd": true,
  "send_info": true,
  "move_completed_path": "/home/MarbolanGos",
  "enc_in_policy": 1,
  "queue_new_to_top": false,
  "ignore_limits_on_local_network": true,
  "rate_limit_ip_overhead": true,
  "daemon_port": 58846,
  "natpmp": true,
  "max_active_limit": 20,
  "utpex": true,
  "max_active_downloading": 3,
  "max_active_seeding": 10,
  "allow_remote": false,
  "max_half_open_connections": 50,
  "download_location": "/media/disk",
  "compact_allocation": false,
  "max_upload_speed": 400.0,
  "cache_expiry": 60,
  "prioritize_first_last_pieces": false,
  "auto_managed": true,
  "enc_level": 1,
  "max_connections_per_second": 20,
  "dont_count_slow_torrents": false,
  "random_outgoing_ports": false,
  "max_upload_slots_per_torrent": -1,
  "new_release_check": true,
  "enc_out_policy": 1,
  "outgoing_ports": [
    56566,
    56566
  ],
  "seed_time_limit": 180,
  "cache_size": 512,
  "share_ratio_limit": 1.5,
  "max_download_speed": -1.0,
  "geoip_db_location": "/usr/share/GeoIP/GeoIP.dat",
  "torrentfiles_location": "/home/MarbolanGos",
  "stop_seed_at_ratio": false,
  "peer_tos": "0x00",
  "listen_interface": "",
  "upnp": true,
  "max_download_speed_per_torrent": -1,
  "max_upload_slots_global": 10,
  "enabled_plugins": [
    "Blocklist",
    "WebUi"
  ],
  "random_port": false,
  "autoadd_enable": false,
  "max_connections_global": 200,
  "enc_prefer_rc4": true,
  "listen_ports": [
    56565,
    56565
  ],
  "dht": true,
  "stop_seed_ratio": 1.5000000000000002,
  "seed_time_ratio_limit": 7.0,
  "max_upload_speed_per_torrent": -1,
  "copy_torrent_file": false,
  "del_copy_torrent_file": false,
  "move_completed": false,
  "proxies": {
    "peer": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    },
    "web_seed": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    },
    "tracker": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    },
    "dht": {
      "username": "",
      "password": "",
      "type": 0,
      "hostname": "",
      "port": 8080
    }
  },
  "add_paused": false,
  "max_connections_per_torrent": -1,
  "remove_seed_at_ratio": false,
  "autoadd_location": "/home/MarbolanGos",
  "plugins_location": "/home/MarbolanGos/.config/deluge/plugins"

What makes me think that it is not an issue from the tracker?

  • The admin of the tracker said that he tried on Ubuntu deluge and it works.
  • I installed transmission (I hate it) and the torrent works.

I am open to any tests in order to make it work!

Cheers, MarbolanGos?

Change History (5)

comment:1 Changed 11 years ago by andar

What version of libtorrent are you using?

comment:2 Changed 11 years ago by MarbolanGos

I was sure to forget something... From the about page: Core Version: 1.3.1 libtorrent version: 0.14.11.0

comment:3 Changed 11 years ago by andar

Can you try using 0.15.5? I'm sure there are https specific fixes in the latest version..

comment:4 Changed 11 years ago by Cas

  • Component changed from other to libtorrent
  • Milestone 1.3.x deleted
  • Priority changed from major to minor
  • Status changed from new to pending
  • Type changed from defect to bug

comment:5 Changed 10 years ago by Cas

  • Resolution set to invalid
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.