Opened 11 years ago

Closed 10 years ago

#1582 closed bug (Fixed)

Wrong path separator returned when moving storage in Windows

Reported by: WillyWolly Owned by: Cas
Priority: trivial Milestone: 1.3.3
Component: GTK UI Version: 1.3.1
Keywords: Cc:

Description

Using the file dialog screen, the save path for a torrent gets saved with backward slashes (as visible in the 'Save Path' column). But when the location is changed afterwards using the file dialog screen those back slashes become forward slashes.

Change History (5)

comment:1 Changed 11 years ago by Cas

  • Component changed from windows to gtkui
  • Milestone changed from 1.3.2 to 1.3.x
  • Summary changed from Windows - inconsistent use of slashes to Files Tab - Remove trailing slash from folders
  • Type changed from defect to bug
  • Version changed from other (please specify) to 1.3.1

The solution is to remove the slash altogether rather than mess around with changing which slash is shown on windows/*nix.

This will need changing for 'Files Tab' in both 'Add Torrents' and StatusBar?

comment:2 Changed 10 years ago by WillyWolly

Yes, it needs changing in the 'Save Path' column. If what you mean by StatusBar? is the lower part of the screen with the tabs, then the File tab over there is OK (it uses a tree structure with appended forward slashes), but the Details tab also contains the wrong slashes in the 'path' entry.

comment:3 Changed 10 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.3
  • Owner set to Cas
  • Status changed from new to accepted

comment:4 Changed 10 years ago by Cas

  • Summary changed from Files Tab - Remove trailing slash from folders to Wrong path separator returned when moving storage in Windows

I see what the problem is now and found libtorrent returns the wrong path separator in Windows but I can apply a workaround for the next release.

comment:5 Changed 10 years ago by Cas

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in 1.3-stable: 52f89270

Note: See TracTickets for help on using tickets.