Opened 10 years ago

Closed 10 years ago

#1846 closed bug (Fixed)

Crash caught by ABRT

Reported by: shnurapet Owned by:
Priority: minor Milestone: Future
Component: Unknown Version: master
Keywords: Cc:

Description

git master as of this hour.

architecture: i686
cmdline: /usr/bin/python /usr/bin/deluge-gtk
component: deluge
executable: /usr/bin/deluge-gtk
kernel: 2.6.35.12-88.fc14.i686
reason: files_tab.py:520:_on_button_press_event:AttributeError: 'NoneType' object has no attribute 'set_sensitive'
release: Fedora release 14 (Laughlin)
time: 1304959632
uid: 500

backtrace
-----
files_tab.py:520:_on_button_press_event:AttributeError: 'NoneType' object has no attribute 'set_sensitive'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge-1.3.900_dev-py2.7.egg/deluge/ui/gtkui/files_tab.py", line 520, in _on_button_press_event
    widget.set_sensitive(not self.__compact)
AttributeError: 'NoneType' object has no attribute 'set_sensitive'

Local variables in innermost frame:
widget: None
self: <deluge.ui.gtkui.files_tab.FilesTab instance at 0x912c82c>
x: 258.0
y: 8.0
path: ((0,), <gtk.TreeViewColumn object at 0x9452edc (GtkTreeViewColumn at 0x931a188)>, 258, 8)
event: <gtk.gdk.Event at 0x9442290: GDK_BUTTON_PRESS x=258,00, y=8,00, button=3>
row: <GtkTreeIter at 0x9654560>


I right-clicked in the files list of a newly added torrent.

Change History (1)

comment:1 Changed 10 years ago by Cas

  • Resolution set to fixed
  • Status changed from new to closed

Couldn't reproduce so assuming fixed now.

Note: See TracTickets for help on using tickets.