Opened 10 years ago

Closed 9 years ago

#1871 closed bug (Fixed)

Disabling classic mode then using connection manager results in rpcserver error

Reported by: brutal_chaos Owned by: Cas
Priority: minor Milestone: 1.3.6
Component: GTK UI Version: 1.3.2
Keywords: Cc:

Description

Description of problem:
rpcserver error on first run switching off classic mode and attempting to connect to the/a daemon.

How reproducible:
Every time.

Steps to Reproduce:

  1. Start with no config. Fresh install or delete/backup your current config.
  2. Start deluge-gtk from bash or your preferred console.
  3. Turn off classic mode
  4. Start the daemon and connect to it.
  5. Watch the error (actual results) repeatedly fly by.

Actual results:

[ERROR   ] 12:03:16 client:454 'NoneType' object has no attribute 'rpcserver'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 452, in call
    m = self.__daemon.rpcserver.get_object_method(method)
AttributeError: 'NoneType' object has no attribute 'rpcserver'
Unhandled error in Deferred:
Unhandled Error
Traceback (most recent call last):
Failure: exceptions.AttributeError: 'NoneType' object has no attribute 'rpcserver'

Expected results:
To not see the error shown in actual results.

Additional info:
Whether or not a daemon is started when you try to connect to it, the error will occur. It seems purely just clicking connect starts spewing the error.

Change History (5)

comment:1 Changed 10 years ago by Cas

  • Milestone changed from Future to 1.3.x

It is documented somewhere that after unchecking classic mode you should close deluge and restart it. The reason for the errors is because you are already connected to the internal daemon and the connection manager does not handle that.

To resolve this we could have a popup when unchecing the classic mode option and also a check in connection mananger for client.classicmode to prevent the errros.

comment:2 Changed 10 years ago by Cas

  • Summary changed from First run rpcserver error to Disabling classic mode then using connection manager results in rpcserver error

comment:3 Changed 9 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.6
  • Owner set to Cas
  • Status changed from new to assigned

comment:4 Changed 9 years ago by gazpachoking

Here's what I'm thinking. Show a dialog when changing classic mode, ask the user if he wants to quit now. (restart would be nice, can't figure out how to do that exactly) The visibility of all the classic mode interface elements (connection manager, quit and shutdown daemon) don't change until user has actually restarted. diff branch

EDIT: The quit dialog should probably be changed to run quit and shutdown daemon when we are enabling classic mode.

comment:5 Changed 9 years ago by gazpachoking

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in 3e98ef5f89a

Note: See TracTickets for help on using tickets.